poj-2406-Power Strings

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = “abc” and b = “def” then a*b = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3
Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

暴力求解

/*
    Name: poj 2406
    Author: long long ago
    Date: 17/03/16 10:04
    Description: http://poj.org/problem?id=2406   kmp算法 
*/

#include <iostream>
#include <cstdio>
#include <vector>
#include <cstring>
#include <cstdlib>
using namespace std;
char a[1000010];
int kmp(int len){
    int i, j, k, ans = 0;
    for (k = 1; k <= len/2; k++){   
        if (len%k)  continue;   //k需要是len的约数 
        for (i = 0; i < len; i++){
            if (a[i%k] != a[i]){
                break;
            }
        }
        if (i == len)   break;
    }
    if (k <= len/2){
        return len/k;
    }else{
        return 1;
    }
}
int main(){
    int i, j, ans, len;
    while(scanf("%s", &a)){
        if (!strcmp(a, ".")){
            break;
        }
        len = strlen(a);
        printf("%d\n", kmp(len));
    }
    return 0;
}

next数组做法
kmp
next表示模式串如果第i位(设str[0]为第0位)与文本串第j位不匹配则要回到第next[i]位继续与文本串第j位匹配。则模式串第1位到next[n]与模式串第n-next[n]位到n位是匹配的。所以思路和上面一样,如果n%(n-next[n])==0,则存在重复连续子串,长度为n-next[n]。

#include<iostream>
#include<string.h>
using namespace std;
int next[1000005];
char s[1000005];
void getnext(){
    int i=0,j=-1;
    next[0]=-1;
    int len=strlen(s);
    while(i<len){
        if(s[i]==s[j]||j==-1){
            i++;
            j++;
            next[i]=j;
        }
        else
            j=next[j];
    }
}
int main(){
    while(scanf("%s",s)>0){
        if(s[0]=='.')
            break;
        int len=strlen(s);
        getnext();
        if(len%(len-next[len])==0)
            printf("%d\n",len/(len-next[len]));
        else
            printf("1\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值