Japan POJ - 3067 (树状数组+升序降序)

Japan
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 26651 Accepted: 7230

Description

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.

Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.

Output

For each test case write one line on the standard output: 
Test case (case number): (number of crossings)

Sample Input

1
3 4 4
1 4
2 3
3 2
3 1

Sample Output

Test case 1: 5

题目分析:

本题有两个要注意的点:1.sum要用longlong型的,虽然有点难找(总共一千的数据量。。)不过遇到树状数组的求和最好把sum直接声明为longlong。

2.降序的时候,注意求和是要getsum(x-1),原因见注释。

题目链接:http://poj.org/problem?id=3067

代码如下:

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
using namespace std;
const int maxx=1000+10;
int N;
int C[maxx];
struct My
{
    int x,y;
} cun[maxx*maxx];

int lowbit(int x)
{
    return x&(-x);
}

void addnum(int x,int d)
{
    while(x<=N)
    {
        C[x]+=d;
        x+=lowbit(x);
    }
}

int getsum(int x)
{
    int ret=0;
    while(x>0)
    {
        ret+=C[x];
        x-=lowbit(x);
    }
    return ret;
}

bool cmp(My a,My b)
{
    if(a.x==b.x)return a.y>b.y;
    else return a.x>b.x;
}

升序
//bool cmp(My a,My b)
//{
//    if(a.x==b.x)return a.y>b.y;
//    else return a.x>b.x;
//}

void init()
{
    memset(C,0,sizeof(C));
}
int main()
{
    int n,m,k,t;
    int icase=1;
    scanf("%d",&t);
    while(t--)
    {
        init();
        scanf("%d%d%d",&n,&m,&k);
        N=max(n,m);
        for(int i=0; i<k; i++)
            scanf("%d%d",&cun[i].x,&cun[i].y);
        sort(cun,cun+k,cmp);
        long long res=0;
        for(int i=0; i<k; i++)
        {
            res+=getsum(cun[i].y-1);//因为之前cun[i].y这个值可能被用过,导致C【un[i].y】不为零,
            //如果不减一,那么之前的那个就会被加入到这次计算当中。
            addnum(cun[i].y,1);

//        //升序
//        res+=getsum(N)-getsum(cun[i].y);
//          addnum(cun[i].y,1);
        }
        printf("Test case %d: %lld\n",icase++,res);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值