Japan(POJ-3067)

Japan(POJ-3067)

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.

Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.

Output

For each test case write one line on the standard output: 
Test case (case number): (number of crossings)

Sample Input

1
3 4 4
1 4
2 3
3 2
3 1

Sample Output

Test case 1: 5

题目翻译:

日本计划迎接ACM ICPC世界总决赛,比赛场地必须修建大量道路。日本是一个高岛,东海岸有N个城市,西海岸有M个城市(M <= 1000, N <= 1000)。K高速公路将被建造。每个海岸上的城市编号为1、2、……从北到南。每条高速公路都是直线,连接着东海岸的城市和西海岸的城市。建设资金由ACM保证。其中很大一部分是由高速公路之间的交叉路口数量决定的。两条高速公路最多在一个地点交叉。编写一个程序来计算高速公路之间的交叉口数量。

输入

输入文件以T开头——测试用例的数量。每个测试用例都以三个数字开始——N、M、K。接下来的K行包含两个数字——由高速公路连接的城市的数字。第一个是东海岸城市的编号第二个是西海岸城市的编号。

思路:求交叉的点数 满足交叉的条件是si<sj&&ei>ej || si>sj&&ei<ej 排好序后就是求终点逆序数了,可以用线段树实现

AC代码:

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <math.h>
#include <algorithm>
#include <stdlib.h>
#include <queue>
#include <stack>
#include <map>
#include <vector>
#define PI 3.1415926
#define inf 0x3f3f3f3f
const int maxn=100010;
using namespace std;
int Sum[maxn<<2];
int A[maxn];
struct node
{
    int x;
    int y;
} s[maxn<<2];
int cmp(node a,node b)
{
    if(a.y!=b.y)
        return a.y>b.y;
    return a.x<b.x;
}
void PushUp(int rt)
{
    Sum[rt]=Sum[rt<<1]+Sum[rt<<1|1];
}
void Update(int x,int l,int r,int rt)
{
    if(l==r)
    {
        Sum[rt]++;
        A[l]++;
        return ;
    }
    int m=(l+r)>>1;
    if(x<=m)
        Update(x,l,m,rt<<1);
    else
        Update(x,m+1,r,rt<<1|1);
    PushUp(rt);
}
int Query(int x,int y,int l,int r,int rt)
{
    if(x<=l && r<=y)
        return Sum[rt];
    int num=0;
    int m=(l+r)>>1;
    if(x<=m)
        num+=Query(x,y,l,m,rt<<1);
    if(m<y)
        num+=Query(x,y,m+1,r,rt<<1|1);
    return num;
}

int main()
{
    int t,n,m,k;
    int sum,cnt=1;
    int i;
    long long ans;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&m,&k);
        memset(Sum,0,sizeof(Sum));
        memset(A,0,sizeof(A));
        ans=0;
        sum=0;
        for(i=1; i<=k; i++)
            scanf("%d%d",&s[i].x,&s[i].y);
        sort(s+1,s+1+k,cmp);
        for(i=1; i<=k; i++)
        {
            int tmp=s[i].y;
            if(i>1 && s[i].y==s[i-1].y)
                sum++;
            else
                sum=0;
            ans+=Query(1,s[i].x,1,n,1)-A[s[i].x]-sum;
            Update(s[i].x,1,n,1);
        }
        printf("Test case %d: %lld\n",cnt++,ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值