Anagrams by Stack-栈的递归调用

Description

How can anagrams result from sequences of stack operations? There are two sequences of stack operators which can convert TROT to TORT:

[
i i i i o o o o
i o i i o o i o
]

where i stands for Push and o stands for Pop. Your program should, given pairs of words produce sequences of stack operations which convert the first word to the second.

Input

The input will consist of several lines of input. The first line of each pair of input lines is to be considered as a source word (which does not include the end-of-line character). The second line (again, not including the end-of-line character) of each pair is a target word. The end of input is marked by end of file.

Output

For each input pair, your program should produce a sorted list of valid sequences of i and o which produce the target word from the source word. Each list should be delimited by

[
]
and the sequences should be printed in "dictionary order". Within each sequence, each  i  and  o  is followed by a single space and each sequence is terminated by a new line.
Process

A stack is a data storage and retrieval structure permitting two operations:

Push - to insert an item and 
Pop - to retrieve the most recently pushed item

We will use the symbol i (in) for push and o (out) for pop operations for an initially empty stack of characters. Given an input word, some sequences of push and pop operations are valid in that every character of the word is both pushed and popped, and furthermore, no attempt is ever made to pop the empty stack. For example, if the word FOO is input, then the sequence:

i i o i o ois valid, but
i i ois not (it's too short), neither is
i i o o o i(there's an illegal pop of an empty stack)

Valid sequences yield rearrangements of the letters in an input word. For example, the input word FOO and the sequence i i o i o oproduce the anagram OOF. So also would the sequence i i i o o o. You are to write a program to input pairs of words and output all the valid sequences of i and o which will produce the second member of each pair from the first.

Sample Input

madam
adamm
bahama
bahama
long
short
eric
rice
Sample Output

[
i i i i o o o i o o 
i i i i o o o o i o 
i i o i o i o i o o 
i i o i o i o o i o 
]
[
i o i i i o o i i o o o 
i o i i i o o o i o i o 
i o i o i o i i i o o o 
i o i o i o i o i o i o 
]
[
]
[
i i o i o i o o 
]
题目大意

模拟栈的操作,使一个字符串a变成想要的另一个字符串b,记录下操作,用i表示入栈,o表示出栈,输出所有可以完成的方式。

代码

#include<iostream>
#include<stack>
#include<vector>
using namespace std;

string a,b;
int len;
stack<char> build;
vector<char> operate;//记录操作


void dfs(int ipush, int ipop)//ipop表示出栈次数(匹配成功才出栈,即匹配成功次数),ipush表示入栈次数
{
    if(ipush == len && ipop == len)//入栈次数和匹配成功次数都等于长度
    {
        for(int i=0;i<operate.size();++i)//这里不是小于len。并且operate.size()应该是len的两倍
            cout << operate[i] << ' ';
        cout<<endl;//因为每种情况后都要有回车,所以回车不能放主函数里。
    }

    if(ipush < len)//23.24.25行和此条件表示把源单词全入完
    {
        build.push(a[ipush]);//入栈
        operate.push_back('i');//记录入栈操作
        dfs(ipush+1,ipop);//当执行【第一次】进入dfs(ipush+1,ipop)ipush=ipush+1,并且ipush<len不成立时,从[最后]一个单词【开始】进行匹配工作(即进入31行)
        build.pop();//恢复一个入栈操作(然后进入31从[最后](相对于【第一次】是倒数第2)一个单词【开始】进行匹配工作)
        operate.pop_back();//记录恢复一个入栈操作
    }


    if(ipop<ipush && ipop<len && build.top()==b[ipop]) //等价于ipop+1<=ipush(ipop和ipush都是从零开始的,ipop=2表示出栈了3次,并且数组下标从零开始)
    {
        char t = build.top();//记录栈顶元素
        build.pop();//抛出栈顶元素即配对成功
        operate.push_back('o');//记录抛出操作
        dfs(ipush,ipop+1);//从倒数第二个单词【继续】匹配
        build.push(t);//恢复抛出,以便下一次搜索
        operate.pop_back();//清除抛出记录
    }


}


int main()
{

    while(cin>>a>>b)
    {
        len=a.length();
        cout<<'['<<endl;
        dfs(0,0);
        cout<<']'<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值