hdu 5916 Harmonic Value Description-思维题-2016中国大学生程序设计竞赛(长春)-重现赛

Harmonic Value Description

Problem Description

The harmonic value of the permutation p1,p2,pn is

i=1n1gcd(pi.pi+1)

Mr. Frog is wondering about the permutation whose harmonic value is the strictly k-th smallest among all the permutations of [n].

 


Input

The first line contains only one integer T ( 1T100 ), which indicates the number of test cases.

For each test case, there is only one line describing the given integers n and k ( 12kn10000 ).

 


Output

For each test case, output one line “Case #x: p1 p2  pn ”, where x is the case number (starting from 1) and p1 p2  pn is the answer.

 


Sample Input

 
 
2 4 1 4 2

 


Sample Output

 
 
Case #1: 4 1 3 2 Case #2: 2 4 1 3

 


Source

2016中国大学生程序设计竞赛(长春)-重现赛

 


题目大意

在1-n的全排列中选出满足这样条件的其中一个排列:

相邻的数两两之间的gcd之和第k小;



解题思路

首先我们很容易得到1-n的顺序排列两两之间的gcd都为1,所以所以这一定是第一小的。

又因为n个数一共有n-1个gcd相加,第二小的一定是某一个gcd变成了2,那么就让2和2*2相邻,这样他俩gcd为2其他都为1,这一定是第二小的。

同理 第三小的一定是某个gcd变成了3,那么就让3和3*2相邻……………………


这里还有个问题是,如果把k直接移到k*2左(右)边位置,那么,k+1和k-1的gcd可能大于1。例如:123456 把3移到6后边,2 4 gcd不为1

那么我们可以按如下顺序输出 :【1~k】、【k*2~n】、【k+1~k*2-1】

这样虽然解决了上述问题,但是n和k+1的gcd可能还不为1

这里发现,1和任意数的gcd都为1,那么我们可以用1把他们隔开


代码

#include <cstdio>
using namespace std;

int main()
{
    int t;
    scanf("%d",&t);
    for(int mcase=1;mcase<=t;++mcase)
    {
        int n,k;
        scanf("%d%d",&n,&k);
        printf("Case #%d: ",mcase);

        for(int i=2;i<=k;++i)
        {
            printf("%d ",i);
        }
        for(int i=2*k;i<=n;++i)
            printf("%d ",i);
        printf("1 ");//n和k+1可能有公因子,所以用1 隔开他们
        for(int i=k+1;i<=2*k-1;++i)
        {
            printf("%d", i);
            if (i < 2 * k - 1)
                putchar(' ');
        }
        putchar('\n');
    }
    return 0;
}


  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值