HDU 6106 Classes -逻辑题-2017多效联盟6 第11题

Classes

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 19    Accepted Submission(s): 16


Problem Description
The school set up three elective courses, assuming that these courses are A, B, C. N classes of students enrolled in these courses.
Now the school wants to count the number of students who enrolled in at least one course in each class and records the maximum number of students.
Each class uploaded 7 data, the number of students enrolled in course A in the class, the number of students enrolled in course B, the number of students enrolled in course C, the number of students enrolled in course AB, the number of students enrolled in course BC, the number of students enrolled in course AC, the number of students enrolled in course ABC. The school can calculate the number of students in this class based on these 7 data.
However, due to statistical errors, some data are wrong and these data should be ignored.
Smart you must know how to write a program to find the maximum number of students.
 

Input
The first line of the input gives the number of test cases T; T test cases follow.
Each case begins with one line with one integer N, indicates the number of class.
Then N lines follow, each line contains 7 data: a, b, c, d, e, f, g, indicates the number of students enrolled in A, B, C, AB, BC, AC, ABC in this class.
It's guaranteed that at least one data is right in each test case.

Limits
T100
1N100
0a,b,c,d,e,f,g100
 

Output
For each test case output one line contains one integer denotes the max number of students who enrolled in at least one course among N classes.
 

Sample Input
   
   
2 2 4 5 4 4 3 2 2 5 3 1 2 0 0 0 2 0 4 10 2 3 4 9 6 12 6 3 5 3 2
 

Sample Output
   
   
7 15
Hint
In the second test case, the data uploaded by Class 1 is wrong. Because we can't find a solution which satisfies the limitation. As for Class 2, we can calculate the number of students who only enrolled in course A is 2, the number of students who only enrolled in course B is 6, and nobody enrolled in course C, the number of students who only enrolled in courses A and B is 1, the number of students who only enrolled in courses B and C is 3, the number of students who only enrolled in courses A and C is 1, the number of students who enrolled in all courses is 2, so the total number in Class 2 is 2 + 6 + 0 + 1 + 3 + 1 + 2 = 15.
 

Source

题意:
n个班每个班的学生报名ABC三种课程,求n个班中 max(只报名A的人+只报名B的人+只报名C+只报名AC+只报名BC+只报名AB+只报名ABC的人)
数据有可能是假的,假的数据直接忽略掉,保证一定有一个真的数据

题解
报名abc的人数一定是只报名abc的人数,那么只报名ab的人数就是 报名ab人数 - 只报名abc人数,ac,bc同理
只报名a的人数一定是 报名a的人数- 只报名ac的人数-只报名ab的人数 - 只报名abc的人数,b,c同理


代码:
#include <iostream>
#include <cstdio>
using namespace std;

int n;

int main()
{
    int t;

    scanf("%d", &t);
    while (t > 0){
        t--;

        scanf("%d", &n);
        int ans = -1;
        for (int i=0; i<n; i++){
            int a, b, c, ab, ac, bc, abc;
            int a1, b1, c1, ab1, ac1, bc1, abc1;
            scanf("%d%d%d%d%d%d%d", &a,&b,&c,&ab,&bc,&ac,&abc);
            abc1 = abc;
            ab1 = ab - abc1;
            ac1 = ac - abc1;
            bc1 = bc - abc1;
            a1 = a - ab1 - ac1 - abc1;
            b1 = b - ab1 - bc1 - abc1;
            c1 = c - ac1 - bc1 - abc1;
            if (a1 < 0 || b1 < 0 || c1 < 0 || ab1 < 0 ||
                bc1 < 0 || ac1 < 0 || abc1 < 0){
                    continue;
                }
            ans = max(ans, a1+b1+c1+ab1+bc1+ac1+abc1);
        }
        cout << ans << endl;
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值