UVA 568 - Just the Facts(数论)

27 篇文章 0 订阅
26 篇文章 0 订阅

Just the Facts

The expression  N !, read as `` N  factorial," denotes the product of the first  N  positive integers, where  N  is nonnegative. So, for example,

NN!
01
11
22
36
424
5120
103628800

For this problem, you are to write a program that can compute the last non-zero digit of any factorial for ($0 \le N \le 10000$). For example, if your program is asked to compute the last nonzero digit of 5!, your program should produce ``2" because 5! = 120, and 2 is the last nonzero digit of 120.

Input 

Input to the program is a series of nonnegative integers not exceeding 10000, each on its own line with no other letters, digits or spaces. For each integer  N , you should read the value and compute the last nonzero digit of  N !.

Output 

For each integer input, the program should print exactly one line of output. Each line of output should contain the value  N , right-justified in columns 1 through 5 with leading blanks, not leading zeroes. Columns 6 - 9 must contain ``  ->  " (space hyphen greater space). Column 10 must contain the single last non-zero digit of  N !.

Sample Input 

1
2
26
125
3125
9999

Sample Input 

1
2
26
125
3125
9999

Sample Output 

    1 -> 1
    2 -> 2
   26 -> 4
  125 -> 8
 3125 -> 2
 9999 -> 8


题意:给出一个整数N,求N!的最后一位非0数字是多少。

看到这个题的第一想法就是用求大数阶乘的方法求出n的阶乘,然后从最后一位开始找,直到找到一个非零的数输出。

#include<stdio.h>
#include<string.h>
int a[30000];
int main()
{
    int n,i,j,c,s;
    while(~scanf("%d",&n))
    {
        memset(a,0,sizeof(a));
        a[0]=1;
        for(i=2; i<=n; i++)
        {
            s=0;
            for(j=0; j<30000; j++)
            {
                c=a[j]*i+s;
                a[j]=c%10;
                s=c/10;
            }
        }
        for(i=0;; i++)
            if(a[i])
            {
                printf("%5d -> %d\n",n,a[i]);
                break;
            }
    }
    return 0;
}


提交以后是Time limit exceed!


后来看了大牛的代码,才知道自己懂得太少了。下面是一种比较容易理解的代码:

#include<stdio.h>
int main()
{
    int n,s,i;
    while(scanf("%d",&n)==1)
    {
        for(i=1,s=1; i<=n; i++)
        {
            s*=i;
            while(s%10==0)
                s/=10;
            s=s%100000;
        }
        printf("%5d -> %d\n",n,s%10);
    }
    return 0;
}


另外让大家看一下大牛们的代码:

#include <stdio.h>
int main()
{
    int n2, n5, i, j, n, digit;
    while(scanf("%d",&n)!=EOF)
    {
        digit = 1;
        n2 = n5 = 0;
        for(i=2; i<=n; i++)
        {
            j = i;
            while(j%2 == 0)
            {
                n2++;
                j /= 2;
            }
            while(j%5 == 0)
            {
                n5++;
                j /= 5;
            }
            digit = (digit * j) % 10;
        }
        for(i=0; i<n2-n5; i++)
            digit = (digit * 2) % 10;
        printf("%5d -> %d\n",n,digit);
    }
    return 0;
}

从2到n,每次更新digit,都先求出该数的2和5的个数,每对2和5相互抵消,每次计算都对10取模,减小计算量。显然2的个数一定比5的个数多。

  • 4
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值