uva 568 - Just the Facts


  Just the Facts 

The expression N!, read as `` N factorial," denotes the product of the first N positive integers, where N is nonnegative. So, for example,

NN!
01
11
22
36
424
5120
103628800

For this problem, you are to write a program that can compute the last non-zero digit of any factorial for ($0 \le N \le 10000$). For example, if your program is asked to compute the last nonzero digit of 5!, your program should produce ``2" because 5! = 120, and 2 is the last nonzero digit of 120.

Input 

Input to the program is a series of nonnegative integers not exceeding 10000, each on its own line with no other letters, digits or spaces. For each integer N, you should read the value and compute the last nonzero digit of N!.

Output 

For each integer input, the program should print exactly one line of output. Each line of output should contain the value N, right-justified in columns 1 through 5 with leading blanks, not leading zeroes. Columns 6 - 9 must contain `` ->" (space hyphen greater space). Column 10 must contain the single last non-zero digit of N!.

Sample Input 

1
2
26
125
3125
9999

Sample Output 

    1 -> 1
    2 -> 2
   26 -> 4
  125 -> 8
 3125 -> 2
 9999 -> 8
数论的方法不太会。开始至保留最有一个非零位数字结果当然不对,产生是因为X5和X10,10好办直接相当于不乘而5的话要找个偶数(取2)匹配消掉,简单的消法是从保留的含有非最后零的数字段中直接除以2,所以导致我们需要保留不止一位数字,n范围小的情况下,保存5位即可,范围大了保存有效数字的范围相应要增大。

#include <stdio.h>

int main()
{int m,n,i,j,pos=100000;
 while (scanf("%d",&n)!=EOF)
 {m=1;
  for (i=1;i<=n;i++)
  {j=i;
   while (j%10==0) j=j/10;
   while (j%5==0) {j=j/5;m=m/2;}
   m=m*j;
   while (m%pos==0) m=m/pos;
   m=m%pos;
  }
  while (m%10==0) m=m%10;
  printf("%5d -> %d\n",n,m%10);
 }
 return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值