06-图2 Saving James Bond - Easy Version (25分)

This time let us consider the situation in the movie "Live and Let Die" in which James Bond, the world's most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape -- he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head... Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).

Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him whether or not he can escape.

Input Specification:

Each input file contains one test case. Each case starts with a line containing two positive integers NN (\le 100100), the number of crocodiles, and DD, the maximum distance that James could jump. Then NN lines follow, each containing the (x, y)(x,y) location of a crocodile. Note that no two crocodiles are staying at the same position.

Output Specification:

For each test case, print in a line "Yes" if James can escape, or "No" if not.

Sample Input 1:

14 20
25 -15
-25 28
8 49
29 15
-35 -2
5 28
27 -29
-8 -28
-20 -35
-25 -20
-13 29
-30 15
-35 40
12 12

Sample Output 1:

Yes

Sample Input 2:

4 13
-12 12
12 12
-12 -12
12 -12

Sample Output 2:

No

题目大意:100*100的湖,中间有个直径为15的岛,湖中有很多鳄鱼,能够跳到它们头上。给定鳄鱼坐标和跳跃距离,问能否跳到岸上。


dfs。如果能能从一只鳄鱼跳到另一只鳄鱼,相当于这两个点之间有边。关键是对第一跳做处理,找出第一跳能够跳到的鳄鱼。


如果能够上岸,打印yes,然后用exit(0)退出程序,也可以标记flag。


#include<stdio.h>
#include<math.h>
#include<stdlib.h>//exit(0);
int n,d,flag=0;
int visit[101]={0};
struct node{
	int x;
	int y;
}stu[101];
double dis(int x,int y){
	return sqrt(x*x+y*y);
}
int canjump(int x1,int y1,int x2,int y2){
	if(sqrt(pow((x1-x2),2)+pow(y1-y2,2))<=d){
		return 1;
	}
	else{
		return 0;
	}
}
void dfs(int s){
	visit[s]=1;
	if(50-abs(stu[s].x)<=d||50-abs(stu[s].y)<=d){
		printf("Yes");
//		flag=1;
		exit(0);
	}
	int i;
	for(i=0;i<n;i++){
		if(visit[i]==0&&canjump(stu[s].x,stu[s].y,stu[i].x,stu[i].y)){
			dfs(i);
		}
	}
}
int main(){
	int i,j;
	scanf("%d %d",&n,&d);
	for(i=0;i<n;i++){
		scanf("%d %d",&stu[i].x,&stu[i].y);
	}
	int firstjump[n];//第一跳下标 
	int numfirst=0;
	for(i=0;i<n;i++){
		if(d+7.5>=dis(stu[i].x,stu[i].y)){
			firstjump[numfirst++]=i;
		}
	}
	for(i=0;i<numfirst;i++){
		if(visit[firstjump[i]]==0){
			dfs(firstjump[i]);
		}
	}
//	if(flag==1){
//		printf("Yes");
//	}
//	else{
		printf("No");
//	}
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值