浙大数据结构习题笔记:06-图2 Saving James Bond - Easy Version (25分)

06-图2 Saving James Bond - Easy Version (25分)

原题

This time let us consider the situation in the movie “Live and Let Die” in which James Bond, the world’s most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape – he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head… Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).

Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him whether or not he can escape.

Input Specification:
Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of crocodiles, and D, the maximum distance that James could jump. Then N lines follow, each containing the (x,y) location of a crocodile. Note that no two crocodiles are staying at the same position.

Output Specification:
For each test case, print in a line “Yes” if James can escape, or “No” if not.

Sample Input 1:

14 20
25 -15
-25 28
8 49
29 15
-35 -2
5 28
27 -29
-8 -28
-20 -35
-25 -20
-13 29
-30 15
-35 40
12 12

Sample Output 1:

Yes

Sample Input 2:

4 13
-12 12
12 12
-12 -12
12 -12

Sample Output 2:

No

分析

英文题目读起来真是费劲……不过看了视频解说后来可以。
主要意思就是,007在(0,0)点,总共有100X100的空间内有N条鳄鱼。每次能跳跃的距离为D,中间是一个直径为15的岛。问每一次踩中鳄鱼后,能否踩出一条路让他到达边界。

解题思路是将鳄鱼的信息记入一个结构中,结构包括横纵坐标,是否访问,是否安全(可以到边界),是否第一步可以跳上。在输入的时候我们需要将其初始化,将横纵坐标输入完毕后,分类使用getSafegetJump两个函数记录这几个鳄鱼的位置。最后使用DFS算法,如果这个鳄鱼是安全的,直接跳出标记isSafe正确,如果不是,标记这个鳄鱼后,DFS根据两个鳄鱼是否小于等于距离且另一只鳄鱼没被遍历,这样遍历全表后,根据isSafe来输出结果

具体代码实现

#include <iostream>
#include <stdlib.h>
#include <cmath>

#define MAX_VERTEX 105

struct Node{
    int hor; //横
    int ver; //纵
    bool visit; //是否访问
    bool safe;  //是否能上岸
    bool jump;  //是否第一布能跳上
};

int N;  //鳄鱼数
int D;  //跳跃距离
bool isSafe; //是否上岸
Node G[MAX_VERTEX]; //鳄鱼信息
using namespace std;
const double diameter = 15;//直径

double getLen(int x1,int y1,int x2,int y2)
{
    return sqrt(pow(x1-x2, 2.0)  + pow(y1-y2, 2.0));
}

//计算鳄鱼是否可以到岸边
bool ifShore(int x,int y)
{
    //计算到四边的直线距离是否小于D
    if(abs(x-50) <= D ||abs(x+50) <= D || abs(y+50) <= D||abs(y-50) <= D)
        return true;
    return false;
}

//确认鳄鱼是否可以上岸
void getSafe()
{
    for(int i=0;i<N;i++){
        if(ifShore(G[i].hor , G[i].ver))
            G[i].safe = true;
        else
            G[i].safe = false;
    }
}

//确认鳄鱼第一部分是否可以跳上去
void getJump()
{
    for(int i=0;i<N;i++){
        //第一步跳到:距离<=跳跃距离+半径
        if(getLen(G[i].hor , G[i].ver , 0,0) <= D+diameter/2)
            G[i].jump = true;
        else
            G[i].jump = false;
    }
}

//初始化
void init()
{
    cin>>N>>D;
    int x,y;
    for(int i=0;i<N;i++){
        cin>>x>>y;
        G[i].hor = x;
        G[i].ver = y;
        G[i].visit = false;
    }
    getSafe();
    getJump();
    isSafe = false;
}

//DFS
void DFS(int v)
{
    if(G[v].safe){
        isSafe = true;
        return;
    }
    G[v].visit = true;
    for(int i=0;i<N;i++){
        if(getLen(G[v].hor , G[v].ver , G[i].hor , G[i].ver) <= D && !G[i].visit)
            DFS(i);
    }
}

//遍历所有集
void listComponent()
{
    for(int i=0;i<N;i++){
        if(G[i].jump)
            DFS(i);
    }
    if(isSafe)
        cout<<"Yes"<<endl;
    else
        cout<<"No"<<endl;
}

int main()
{
    init();
    listComponent();
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值