Saving James Bond - Easy Version

This time let us consider the situation in the movie “Live and Let Die” in which James Bond, the world’s most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape – he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head… Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).

Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him whether or not he can escape.

Input Specification:

Each input file contains one test case. Each case starts with a line containing two positive integers NN (\le 100≤100), the number of crocodiles, and DD, the maximum distance that James could jump. Then NN lines follow, each containing the (x, y)(x,y) location of a crocodile. Note that no two crocodiles are staying at the same position.

Output Specification:

For each test case, print in a line “Yes” if James can escape, or “No” if not.

Sample Input 1:

14 20
25 -15
-25 28
8 49
29 15
-35 -2
5 28
27 -29
-8 -28
-20 -35
-25 -20
-13 29
-30 15
-35 40
12 12
Sample Output 1:

Yes
Sample Input 2:

4 13
-12 12
12 12
-12 -12
12 -12
Sample Output 2:

No

简单的图的遍历,就当作是对DFS新手的练习吧,使用数组更方便一些,当然我是看了别人的代码才有的思路。。

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
int n,r;
double a[200];
int visited[200];
bool IsSafe(double d){
    if(50-d<=r){
        return true;
    }
    else{
        return false;
    }
}
bool FirstJump(double d){
    if(d<=r+15/2){
        return true;
    }else{
        return false;
    }
}
bool Jump(double d1,double d2){
    if(abs(d1-d2)<=r){
        return true;
    }else{
        return false;
    }
}
int DFS(int i){
    visited[i]=1;
    int flag=0;
    if(IsSafe(a[i])){
        flag=1;
    }
    for(int j=0;j<=n;j++){
        if(Jump(a[j],a[i])&&!visited[j]){
            flag=DFS(j);
        }
        if(flag==1){
            break;
        }
    }
    return flag;
}
int main(){
    cin>>n>>r;
    int i,x,y,flag;
    for(i=0;i<n;i++){
        cin>>x>>y;
        a[i]=sqrt(x*x+y*y);
    }
    for(int i=0;i<n;i++){
        if(FirstJump(a[i])&&!visited[i]){
            flag=DFS(i);
            if(flag==1){
                break;
            }
        }
    }
    if(flag==1){
        cout<<"Yes"<<endl;
    }else{
        cout<<"No"<<endl;
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值