1020. Tree Traversals (25)


时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2

给定后序和中序,求层次遍历。


好好背模板。


#include<stdio.h>
#include<stdlib.h>
#include<queue>
using namespace std;
int post[35],in[35];
typedef struct Node *node;
struct Node{
	int x;
	node left;
	node right;
};
node build(int s1,int e1,int s2,int e2){
	node T=NULL;
	if(!T){
		T=(node)malloc(sizeof(struct Node));
		T->left=T->right=NULL;
		T->x=post[e1];
	}
	int root,i;
	for(i=s2;i<=e2;i++){
		if(in[i]==post[e1]){
			root=i;break;
		}
	}
	if(root!=s2){
		T->left=build(s1,root-s2+s1-1,s2,root-1);
	}
	if(root!=e2){
		T->right=build(root-s2+s1,e1-1,root+1,e2);
	}
	return T;
}
int main(){
	int n,i;
	scanf("%d",&n);
	for(i=0;i<n;i++){
		scanf("%d",&post[i]);
	}
	for(i=0;i<n;i++){
		scanf("%d",&in[i]);
	}
	node T=NULL;
	T=build(0,n-1,0,n-1);
	int flag=0;
	queue<node>q;
	q.push(T);
	while(!q.empty()){
		node head=q.front();
		q.pop();
		if(flag==0){
			printf("%d",head->x);flag=1;
		}
		else{
			printf(" %d",head->x);
		}
		if(head->left){
			q.push(head->left);
		}
		if(head->right){
			q.push(head->right);
		}
	} 
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值