1043. Is It a Binary Search Tree (25)

1043. Is It a Binary Search Tree (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line "YES" if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or "NO" if not. Then if the answer is "YES", print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:
7
8 6 5 7 10 8 11
Sample Output 1:
YES
5 7 6 8 11 10 8
Sample Input 2:
7
8 10 11 8 6 7 5
Sample Output 2:
YES
11 8 10 7 5 6 8
Sample Input 3:
7
8 6 8 5 10 9 11
Sample Output 3:
NO
#include<stdio.h>
#include<vector>
#include<stdlib.h>
using namespace std;
vector<int>orign,pre,prem,post,postm;
typedef struct Node *node;
struct Node{
	int x;
	node left;
	node right;
};
node insert(node T,int x){
	if(T==NULL){
		T=(node)malloc(sizeof(struct Node));
		T->x=x;
		T->left=T->right=NULL;
	}
	else if(x<T->x){
		T->left=insert(T->left,x);
	}
	else{
		T->right=insert(T->right,x);
	}
	return T;
}
void preorder(node T){
	if(T){
		pre.push_back(T->x);
		preorder(T->left);
		preorder(T->right);
	}
}
void premorder(node T){
	if(T){
		prem.push_back(T->x);
		premorder(T->right);
		premorder(T->left);		
	}
}
void postorder(node T){
	if(T){
		postorder(T->left);
		postorder(T->right);
		post.push_back(T->x);
	}
}
void postmorder(node T){
	if(T){
		postmorder(T->right);
		postmorder(T->left);		
		postm.push_back(T->x);
	}
}
void print(vector<int> a){
	for(int i=0;i<a.size();i++){
		printf("%d",a[i]);
		if(i!=a.size()-1){
			printf(" ");
		}		
	}
}
int main(){
	int i,n,temp;
	node T=NULL;
	scanf("%d",&n);
	for(i=0;i<n;i++){
		scanf("%d",&temp);
		T=insert(T,temp);
		orign.push_back(temp);
	}
	preorder(T);
	premorder(T);
	if(orign==pre){
		printf("YES\n");
		postorder(T);
		print(post);
	}
	else if(orign==prem){
		printf("YES\n");
		postmorder(T);
		print(postm);
	}
	else{
		printf("NO\n");
	}
}




Python网络爬虫与推荐算法新闻推荐平台:网络爬虫:通过Python实现新浪新闻的爬取,可爬取新闻页面上的标题、文本、图片、视频链接(保留排版) 推荐算法:权重衰减+标签推荐+区域推荐+热点推荐.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值