精解1043. Is It a Binary Search Tree (25)-PAT甲级真题

1043. Is It a Binary Search Tree (25)-PAT甲级真题

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node’s key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO

题意:给出一对整数序列,判断此序列是否为对一颗二叉搜索树或其镜像进行偏序遍历的结果

分析:建议看柳婼学姐的 题解,此处给出一些细节详细解释帮助理解

完整代码:

#include<iostream>
#include<vector>
using namespace std;
bool isMir;
vector<int> pre, post;
void getpost(int root, int tail) {
    if(root > tail) return ;
    int i=root+1, j=tail;
    if(!isMir) {
        while(i <= tail && pre[root] > pre[i]) i++;
        while(j > root && pre[root] <= pre[j]) j--;
    } else {
        while(i <= tail && pre[root] <= pre[i]) i++;
        while(j > root && pre[root] > pre[j]) j--;
    }
    if(i - j != 1) return ;
    getpost(root+1, j);
    getpost(i, tail);
    post.push_back(pre[root]);
}

int main()
{
    //freopen("input.in", "r", stdin);
    int n;
    cin>>n;
    pre.resize(n);
    for(int i=0; i<n; i++)
        cin>>pre[i];
    getpost(0, n-1);
    if(post.size() != n) {
        isMir=true;
        post.clear();
        getpost(0, n-1);
    }
    if(post.size() == n) {
        cout<<"YES\n";
        cout<<post[0];
        for(int i=1; i<post.size(); i++)
            cout<<' '<<post[i];
    } else {
        cout<<"NO"<<endl;
    }
}

代码剖析:

1. 对于代码line:7-15,第7行为退出条件,我们先观察10-11行,

//10-11行代码片段
while(i <= tail && pre[root] > pre[i]) i++;
while(j > root && pre[root] <= pre[j]) j--;
我们可以构造实例来理解,对于 10 5 3 9 20 15 30 画出下图:

pat1043

第一个while循环while(i <= tail && pre[root] > pre[i]) i++;,从该序列从左往右找到第一个大于根(root)的节点的下标, 此处第一层递归为i = 4,
第二个while循环while(j > root && pre[root] <= pre[j]) j--;, 从该序列从右往左找到第一个小于根节点的下标,此处第一层递归为j = 3,至于为什么一定可以这样比较呢,因为前序遍历对应序列的特性:根(10) 左(5 3 9) 右(20 15 30),从而我们知道第16行代码设置的含义:是为了确定这一层满足二叉树特性(root > leftChild && root < rightChild),然后才能进入下一层
同样理解line: 13-14
柳婼博主大大的代码真的简洁完美,强推!
  • 3
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值