1043. Is It a Binary Search Tree (25)【二叉树】——PAT (Advanced Level) Practise

题目信息

1043. Is It a Binary Search Tree (25)

时间限制400 ms
内存限制65536 kB
代码长度限制16000 B

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line “YES” if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or “NO” if not. Then if the answer is “YES”, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:
7
8 6 5 7 10 8 11
Sample Output 1:
YES
5 7 6 8 11 10 8
Sample Input 2:
7
8 10 11 8 6 7 5
Sample Output 2:
YES
11 8 10 7 5 6 8
Sample Input 3:
7
8 6 8 5 10 9 11
Sample Output 3:
NO

解题思路

分别以最大和最小序建立两棵树,然后比较前序遍历与数据是否一致。注意建树时比较方式要对称

AC代码

#include <cstdio>
#include <vector>
#include <algorithm>
#include <cstring>
using namespace std;
struct Node{
    Node *left, *right;
    int v;
};
Node* create(int v){
    Node *h = new Node();
    h->left = h->right = NULL;
    h->v = v;
    return h;
}
Node* insert1(Node *root, int v){
    if (root == NULL){
        return create(v);
    }else{
        if (v < root->v){
            root->left = insert1(root->left, v);
        }else{
            root->right = insert1(root->right, v);
        }
    }
    return root;
}
Node* insert2(Node *root, int v){
    if (root == NULL){
        return create(v);
    }else{
        if (v >= root->v){
            root->left = insert2(root->left, v);
        }else{
            root->right = insert2(root->right, v);
        }
    }
    return root;
}
void preOrder(Node* root, vector<int> &v){
    v.push_back(root->v);
    if (root->left) preOrder(root->left, v);
    if (root->right) preOrder(root->right, v);
}
void postOrder(Node* root, vector<int> &v){
    if (root->left) postOrder(root->left, v);
    if (root->right) postOrder(root->right, v);
    v.push_back(root->v);
}
int main()
{
    int n, t;
    scanf("%d", &n);
    vector<int> v, v1, v2, rs;
    Node *t1 = NULL, *t2 = NULL;
    for (int i = 0; i < n; ++i){
        scanf("%d", &t);
        v.push_back(t);
        t1 = insert1(t1, t);
        t2 = insert2(t2, t);
    }
    preOrder(t1, v1);
    preOrder(t2, v2);

    if (v == v1){
        printf("YES\n");
        postOrder(t1, rs);
        printf("%d", rs[0]);
        for (int i = 1; i < rs.size(); ++i){
            printf(" %d", rs[i]);
        }
    }else if (v == v2){
        printf("YES\n");
        postOrder(t2, rs);
        printf("%d", rs[0]);
        for (int i = 1; i < rs.size(); ++i){
            printf(" %d", rs[i]);
        }
    }else{
        printf("NO");
    }
    printf("\n");
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
下面是用C语言实现的代码,判断一棵二叉树是否为完全二叉树。 ```c #include <stdio.h> #include <stdlib.h> #include <stdbool.h> typedef struct TreeNode { int val; struct TreeNode *left; struct TreeNode *right; } TreeNode; typedef struct Queue { TreeNode **data; int front; int rear; int size; } Queue; Queue *createQueue(int size) { Queue *q = (Queue *)malloc(sizeof(Queue)); q->data = (TreeNode **)malloc(sizeof(TreeNode *) * size); q->front = q->rear = 0; q->size = size; return q; } bool isEmpty(Queue *q) { return q->front == q->rear; } bool isFull(Queue *q) { return (q->rear + 1) % q->size == q->front; } void enqueue(Queue *q, TreeNode *node) { if (isFull(q)) { return; } q->data[q->rear] = node; q->rear = (q->rear + 1) % q->size; } TreeNode *dequeue(Queue *q) { if (isEmpty(q)) { return NULL; } TreeNode *node = q->data[q->front]; q->front = (q->front + 1) % q->size; return node; } bool isCompleteTree(TreeNode* root) { if (root == NULL) { return true; } Queue *q = createQueue(1000); bool flag = false; enqueue(q, root); while (!isEmpty(q)) { TreeNode *node = dequeue(q); if (node->left) { if (flag) { return false; } enqueue(q, node->left); } else { flag = true; } if (node->right) { if (flag) { return false; } enqueue(q, node->right); } else { flag = true; } } return true; } int main() { TreeNode *root = (TreeNode *)malloc(sizeof(TreeNode)); root->val = 1; root->left = (TreeNode *)malloc(sizeof(TreeNode)); root->left->val = 2; root->right = (TreeNode *)malloc(sizeof(TreeNode)); root->right->val = 3; root->left->left = (TreeNode *)malloc(sizeof(TreeNode)); root->left->left->val = 4; root->left->right = (TreeNode *)malloc(sizeof(TreeNode)); root->left->right->val = 5; root->right->left = (TreeNode *)malloc(sizeof(TreeNode)); root->right->left->val = 6; printf("%s\n", isCompleteTree(root) ? "true" : "false"); return 0; } ``` 代码中使用了队列来存储二叉树中的节点,判断是否为完全二叉树的方法是,从根节点开始,每层的节点必须都存在,否则后面的节点都必须是叶子节点才满足完全二叉树的定义。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值