HDU-1385-Minimum Transport Cost

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1385

Minimum Transport Cost

Problem Description
These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts: 
The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.
 

Input
First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1 b2 ... bN

c d
e f
...
g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:
 

Output
From c to d :
Path: c-->c1-->......-->ck-->d
Total cost : ......
......

From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.  

Sample Input
  
  
5 0 3 22 -1 4 3 0 5 -1 -1 22 5 0 9 20 -1 -1 9 0 4 4 -1 20 4 0 5 17 8 3 1 1 3 3 5 2 4 -1 -1 0
 
Sample Output
  
  
From 1 to 3 : Path: 1-->5-->4-->3 Total cost : 21 From 3 to 5 : Path: 3-->4-->5 Total cost : 16 From 2 to 4 : Path: 2-->1-->5-->4 Total cost : 17


题目分析:找一个路径使得从一个点到另外一个点花费(距离+tax)最小,其中除了起点和终点,途中经过的站点要收费 。用floyd算法求出最短路径,并且要按照字典序保存最短路径。打印路径,path[i][j]是不断的记录i的直接后驱,即从i到j经过的第一个站。还需注意如果起点==终点的时候 正确路径只有一个点而不是a-->a。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int inf=999999;
int e[111][111],tax[111],path[111][111];
int n;
void floyd()
{
	int i,j,k;
	for(k=1;k<=n;k++)
	{
		for(i=1;i<=n;i++)
		{
			if(e[i][k]!=inf)
			{
				for(j=1;j<=n;j++)
				{
					if(e[i][j]>e[i][k]+e[k][j]+tax[k])
					{
						e[i][j]=e[i][k]+e[k][j]+tax[k];
						path[i][j]=path[i][k]; 
					}
					//路径相等按字典序选择。 
					else if(e[i][j]==e[i][k]+e[k][j]+tax[k]&&path[i][j]>path[i][k])
					{
						path[i][j]=path[i][k];
					} 
				}
			}
		}
	}
}
int  main()
{
	int i,j,u,v;
	while(~scanf("%d",&n))
	{
		if(n==0)
		break;
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=n;j++)
			{
				scanf("%d",&e[i][j]);
				if(e[i][j]==-1)
				{
					e[i][j]=inf;
				}
				path[i][j]=j;//初始化表示从i到j经过的第一个站。 
			}
		}
		for(i=1;i<=n;i++)
		{
			scanf("%d",&tax[i]);
		}
		floyd();
		while(scanf("%d%d",&u,&v))
		{
			if(u==-1&&v==-1)
			break;
			printf("From %d to %d :\n",u,v);
			printf("Path: %d",u);
			int st,en;
			st=u,en=v;
			while(u!=v)
			{
				printf("-->%d",path[u][v]);
				u=path[u][v];
			}
			printf("\nTotal cost : %d\n\n",e[st][en]);
		}	
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值