usaco3.3.1 Riding the Fences

一 原题

Riding the Fences

Farmer John owns a large number of fences that must be repaired annually. He traverses the fences by riding a horse along each and every one of them (and nowhere else) and fixing the broken parts.

Farmer John is as lazy as the next farmer and hates to ride the same fence twice. Your program must read in a description of a network of fences and tell Farmer John a path to traverse each fence length exactly once, if possible. Farmer J can, if he wishes, start and finish at any fence intersection.

Every fence connects two fence intersections, which are numbered inclusively from 1 through 500 (though some farms have far fewer than 500 intersections). Any number of fences (>=1) can meet at a fence intersection. It is always possible to ride from any fence to any other fence (i.e., all fences are "connected").

Your program must output the path of intersections that, if interpreted as a base 500 number, would have the smallest magnitude.

There will always be at least one solution for each set of input data supplied to your program for testing.

PROGRAM NAME: fence

INPUT FORMAT

Line 1:The number of fences, F (1 <= F <= 1024)
Line 2..F+1:A pair of integers (1 <= i,j <= 500) that tell which pair of intersections this fence connects.

SAMPLE INPUT (file fence.in)

9
1 2
2 3
3 4
4 2
4 5
2 5
5 6
5 7
4 6

OUTPUT FORMAT

The output consists of F+1 lines, each containing a single integer. Print the number of the starting intersection on the first line, the next intersection's number on the next line, and so on, until the final intersection on the last line. There might be many possible answers to any given input set, but only one is ordered correctly.

SAMPLE OUTPUT (file fence.out)

1
2
3
4
2
5
4
6
5
7


二 分析

如果一个图有欧拉回路。那么度数为奇数的顶点要么是0个,要么是2个。如果是0个,选标号最小的顶点开始找欧拉回路;如果有2个,找度为奇数的顶点中标号较小的那个顶点开始找欧拉回路。前9次提交都没有想出来找欧拉回路的O(|E|)算法。然后就疯狂TLE。看了NOCOW这题的讲解之后终才会了。。链接:http://www.nocow.cn/index.php/USACO/fence


三 代码

运行结果:
USER: Qi Shen [maxkibb3]
TASK: fence
LANG: C++

Compiling...
Compile: OK

Executing...
   Test 1: TEST OK [0.000 secs, 5164 KB]
   Test 2: TEST OK [0.000 secs, 5164 KB]
   Test 3: TEST OK [0.000 secs, 5164 KB]
   Test 4: TEST OK [0.000 secs, 5164 KB]
   Test 5: TEST OK [0.000 secs, 5164 KB]
   Test 6: TEST OK [0.000 secs, 5164 KB]
   Test 7: TEST OK [0.000 secs, 5164 KB]
   Test 8: TEST OK [0.000 secs, 5164 KB]

All tests OK.

Your program ('fence') produced all correct answers! This is your submission #10 for this problem. Congratulations!


AC代码:
/*
ID:maxkibb3
LANG:C++
PROG:fence
*/

#include<cstdio>
#include<vector>
using namespace std;

const int MAX_V = 501;

int n;
int map[MAX_V][MAX_V];
int edge_num[MAX_V];
vector<int> trace;

void dfs(int pos) {
	for(int i = 1; i < MAX_V; i++) {
		if(map[pos][i] != 0) {
			map[pos][i]--;
			map[i][pos]--;
			dfs(i);
		}
	}
	trace.push_back(pos);
}

int main() {
	freopen("fence.in", "r", stdin);
	freopen("fence.out", "w", stdout);
	scanf("%d", &n);
	int s, e;
	for(int i = 0; i < n; i++) {
		scanf("%d%d", &s, &e);
		map[s][e]++;
		map[e][s]++;
		edge_num[s]++;
		edge_num[e]++;
	}
	
	for(int i = 1; i < MAX_V; i++) {
		if(edge_num[i] % 2 == 1) {
			dfs(i);
			break;
		}
	}
	
	if(trace.size() == 0) {
		for(int i = 1; i < MAX_V; i++) {
			if(edge_num[i] != 0) {
				dfs(i);
				break;
			}
		}	
	}
	
	for(int i = trace.size() - 1; i >= 0; i--) {
		printf("%d\n", trace[i]);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值