Riding the Fences (USACO 3.3) 无向图欧拉通路/回路

Riding the Fences

Farmer John owns a large number of fences that must be repaired annually. He traverses the fences by riding a horse along each and every one of them (and nowhere else) and fixing the broken parts.

Farmer John is as lazy as the next farmer and hates to ride the same fence twice. Your program must read in a description of a network of fences and tell Farmer John a path to traverse each fence length exactly once, if possible. Farmer J can, if he wishes, start and finish at any fence intersection.

Every fence connects two fence intersections, which are numbered inclusively from 1 through 500 (though some farms have far fewer than 500 intersections). Any number of fences (>=1) can meet at a fence intersection. It is always possible to ride from any fence to any other fence (i.e., all fences are "connected").

Your program must output the path of intersections that, if interpreted as a base 500 number, would have the smallest magnitude.

There will always be at least one solution for each set of input data supplied to your program for testing.

PROGRAM NAME: fence

INPUT FORMAT

Line 1:The number of fences, F (1 <= F <= 1024)
Line 2..F+1:A pair of integers (1 <= i,j <= 500) that tell which pair of intersections this fence connects.

SAMPLE INPUT (file fence.in)

9
1 2
2 3
3 4
4 2
4 5
2 5
5 6
5 7
4 6

OUTPUT FORMAT

The output consists of F+1 lines, each containing a single integer. Print the number of the starting intersection on the first line, the next intersection's number on the next line, and so on, until the final intersection on the last line. There might be many possible answers to any given input set, but only one is ordered correctly.

SAMPLE OUTPUT (file fence.out)

1
2
3
4
2
5
4
6
5
7

两点注意:首先,没有跟你说点的序号一定是从1开始的两个点之间可能有不止一条道路。


/* 
ID: hysfwjr1
PROG: fence 
LANG: C++ 
*/
#include <stdio.h>
#include <stdlib.h>
#include <assert.h>
#include <memory.h>
#define _DEBUG 0
#define MAXN 502
#define MAXE  1025

int fence[MAXN][MAXN];
int degree[MAXN];
int path[MAXE<<1];//路径节点
int pc=0;//路径节点计数

void Eulerian(int start){
	assert(start>=0);
	if(degree[start]>0){
		for(int i=1;i<=MAXN;i++){
			if(fence[start][i]>0){//可能不止一条边
				//去掉此路径
				degree[start]--;
				degree[i]--;
				fence[start][i]--;
				fence[i][start]--;
				Eulerian(i);
			}
		}		
	}
	path[pc++]=start;
}


int main(){
	freopen("fence.in","r",stdin);
#if _DEBUG==0
	freopen("fence.out","w",stdout);
#endif
	int e;
	int i;
	scanf("%d",&e);
	int u,v;
	for(i=0;i<e;i++){
		scanf("%d %d",&u,&v);
		degree[u]++;degree[v]++;
		fence[u][v]++;fence[v][u]++;
	}
	//寻找起点
	int start=-1;
	for(i=1;i<=MAXN;i++)//寻找第1个度不为0的点
		if(degree[i]!=0){
			start=i;
			break;
		}
	for(i=start;i<=MAXN;i++){//寻找第1个度为奇数的点
		if(degree[i]&0x1){
			start=i;
			break;
		}
	}
	Eulerian(start);
	for(i=pc-1;i>=0;i--){
		printf("%d\n",path[i]);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值