Hdu 4283 You Are the One【区间Dp+思维】好题!

You Are the One

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3950    Accepted Submission(s): 1826


Problem Description
  The TV shows such as You Are the One has been very popular. In order to meet the need of boys who are still single, TJUT hold the show itself. The show is hold in the Small hall, so it attract a lot of boys and girls. Now there are n boys enrolling in. At the beginning, the n boys stand in a row and go to the stage one by one. However, the director suddenly knows that very boy has a value of diaosi D, if the boy is k-th one go to the stage, the unhappiness of him will be (k-1)*D, because he has to wait for (k-1) people. Luckily, there is a dark room in the Small hall, so the director can put the boy into the dark room temporarily and let the boys behind his go to stage before him. For the dark room is very narrow, the boy who first get into dark room has to leave last. The director wants to change the order of boys by the dark room, so the summary of unhappiness will be least. Can you help him?
 

Input
  The first line contains a single integer T, the number of test cases.  For each case, the first line is n (0 < n <= 100)
  The next n line are n integer D1-Dn means the value of diaosi of boys (0 <= Di <= 100)
 

Output
  For each test case, output the least summary of unhappiness .
 

Sample Input
  
  
2    5 1 2 3 4 5 5 5 4 3 2 2
 

Sample Output
  
  
Case #1: 20 Case #2: 24
 

Source


题目大意:


现在给你N个人排成一列,同时现在有一个小黑屋,小黑屋很窄,只能使得先进去的人最后出来,第K个上台的人会获得(K-1)*a[i]的不高兴值,问怎样分配登台顺序使得不高兴值最小,问最小是多少。


思路:


求最优解,并且观察到数据范围不大,那么我们考虑区间Dp.

设定Dp【i】【j】表示区间【i,j】的所有人都上台了的最小不高兴值。

那么我们通过先处理小区间的最优解,来动态规划出大区间的最优解。


那么其状态转移不难写出:



然而我们这样写只有一次小黑屋从无变有的状态。

然而整个过程可能会有多次小黑屋从无变有的状态。

那么这里我们就需要进行区间合并。


然而区间合并也要要求一个限制,就是如果有三个区间【A】【B】【C】.如果A区间的人已经上过台了,那么B区间就一定已经上过台了,所以我们对于两个区间进行合并操作的时候【A】【B】-------->【A+B】需要保证A在B前边。

也就是说区间合并的时候转移方程只能有一种:


区间合并其实就是让另一个区间的所有人的不高兴值都提升当前区间的人数的倍数。


注意实现细节就没有别的什么别的内容了。


Ac代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
int a[150];
int sum[150];
int dp[150][150];
int main()
{
    int kase=0;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        memset(sum,0,sizeof(sum));
        for(int i=1;i<=n;i++)scanf("%d",&a[i]),sum[i]=sum[i-1]+a[i];
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                dp[i][j]=0x3f3f3f3f;
            }
        }
        for(int len=0;len<=n;len++)
        {
            for(int i=1;i<=n;i++)
            {
                int j=i+len;
                if(len==0)
                {
                    dp[i][i]=0;
                }
                if(j<=n)
                {
                    dp[i][j]=min(dp[i][j],dp[i][j-1]+(j-i)*a[j]);
                    dp[i][j]=min(dp[i][j],dp[i+1][j]+(j-i)*a[i]);
                    for(int k=i;k<j;k++)
                    {
                        dp[i][j]=min(dp[i][j],dp[i][k]+dp[k+1][j]+(sum[j]-sum[k])*(k-i+1));
                    }
                }
            }
        }
        printf("Case #%d: ",++kase);
        printf("%d\n",dp[1][n]);
    }
}











评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值