poj 2492 A Bug's Life(并查集 染色法 二分图)

链接:http://poj.org/problem?id=2492

A Bug's Life
Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 35997 Accepted: 11796

Description

Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.

题意:

有n组数据,每组数据第一行为m(人数)和p(配对数),每个配对必须是男女,不能男男或女女,问是否有人即使男又是女

思路:

染色法判二分图,注意不止一个性别圈,可能有很多性别圈,要从1到n遍历一遍


写的很快,但是n和m混了,导致答案一直不对,找到bug提交两次pe,第一次没注意输出后有两个回车,第二次以为最后一个例子输出后不用空行,结果两次pe= =

每次输出都有空行

代码:

#define _CRT_SBCURE_MO_DEPRECATE    
#include<iostream>    
#include<stdlib.h>    
#include<stdio.h>    
#include<cmath>    
#include<algorithm>    
#include<string>    
#include<string.h>    
#include<set>    
#include<queue>    
#include<stack>    
#include<functional>     
using namespace std;
const int maxn = 1000000 + 10;
const int INF = 0x3f3f3f3f;
typedef long long ll;

int n;
int m, p;
int a, b;
int color[maxn];
vector<int>G[maxn];

void init() {
	for (int i = 0; i<maxn; i++) {
		G[i].clear();
		color[i] = 0;
	}
}

int bipartite(int s) {
	int u, v;
	queue<int>Q;
	color[s] = 1;
	Q.push(s);
	while (!Q.empty()) {
		u = Q.front();
		Q.pop();
		for (int i = 0; i < G[u].size(); i++) {
			v = G[u][i];
			if (color[v] == 0) {
				color[v] = -color[u];
				Q.push(v);
			}
			else if (color[v] == color[u]) {
				return 0;
			}
		}
	}
//	cout << "yes" << endl;
	return 1;
}

int main() {
	scanf("%d", &n);
	int k = 1;
	while (n--) {
		scanf("%d %d", &m, &p);
		init();
		for (int i = 1; i <= p; i++) {
			scanf("%d %d", &a, &b);
			G[a].push_back(b);
			G[b].push_back(a);
		}
		int flag = 1;
		for (int i = 1; i <= m; i++) {
			if (color[i] == 0) {
				flag = bipartite(i);
				//cout << flag << endl;
			}
			if (!flag) {
				break;
			}
		}
		printf("Scenario #%d:\n", k++);
		
		if (flag) printf("No suspicious bugs found!\n");
		else printf("Suspicious bugs found!\n");
		cout << endl;
	}
	//system("pause");
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值