POJ 2524-Ubiquitous Religions(入门并查集)

Ubiquitous Religions

Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 30241 Accepted: 14633

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output

Case 1: 1
Case 2: 7

Hint

Huge input, scanf is recommended.

Source

Alberta Collegiate Programming Contest 2003.10.18

题目意思:
学校有n个人,编号1 到 n;
下面输入 m 行,每行两个人,两个人在一个种族中;
如果有人不在这个学校中,即编号大于n,则忽略不计;

学校想给每个种族发一种东西,所以你要统计共有多少个种族,如果此人没有出现,则可认为所有没出现的一个人自信仰一个种族;

输出共有多少个种族。

/* 
* Copyright (c) 2016, 烟台大学计算机与控制工程学院 
* All rights reserved. 
* 文件名称:father.cpp 
* 作    者:单昕昕 
* 完成日期:2016年1月19日 
* 版 本 号:v1.0 
*/ 
#include <stdio.h>
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<vector>
#include<cmath>
using namespace std;
int set[50000+5];
int set_find(int p)
{
    if(set[p]==0)
        return p;
    return set[p]=set_find(set[p]);
}
void join(int p,int q)
{
    int p1,q1;
    p1=set_find(p);
    q1=set_find(q);
    if(p1!=q1)
        set[p1]=q1;
}
int main()
{
    int n, m, i, j,ans,cnt=0;
    while(scanf("%d%d", &n, &m)&&n&&m)
    {
        ans=0;
        memset(set,0,sizeof(set));
        while(m--)
        {
            scanf("%d%d", &i, &j);
            join(i,j);
        }
        for(int i=1; i<=n; i++)
            if(set[i]==0)
                ans++;
        printf( "Case %d: %d\n",++cnt, ans);
    }
    return 0;
}

参照啊哈算法,初始化为i
/*
* Copyright (c) 2016, 烟台大学计算机与控制工程学院
* All rights reserved.
* 文件名称:father.cpp
* 作    者:单昕昕
* 完成日期:2016年1月19日
* 版 本 号:v2.0
*/
#include <stdio.h>
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<vector>
#include<cmath>
using namespace std;
int set[50000+5];
int n;
void init()
{
    for(int i=1;i<=n;++i)
        set[i]=i;
}
int set_find(int p)
{
    if(set[p]==p)
        return p;
    set[p]=set_find(set[p]);
    //cout<<"set["<<p<<"]= "<<set[p]<<endl;
    return set[p];
}
void join(int p,int q)
{
    int p1,q1;
    p1=set_find(p);
    q1=set_find(q);
    if(p1!=q1)
      {
          set[p1]=q1;
          //cout<<"!!!";
      }
    //cout<<"set["<<p1<<"]= "<<set[p1]<<"join"<<endl;
}
int main()
{
    int m, i, j,ans,cnt=0;
    while(scanf("%d%d", &n, &m)&&n&&m)
    {
        init();
        ans=0;
        while(m--)
        {
            scanf("%d%d", &i, &j);
            join(i,j);
        }
        for(int i=1; i<=n; i++)
          {
              cout<<set[i]<<endl;
              if(set[i]==i)
                ans++;
          }
        printf( "Case %d: %d\n",++cnt, ans);
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值