POJ2524--Ubiquitous Religions(并查集)

26 篇文章 0 订阅

Do more with less

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.
You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

nput

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output

Case 1: 1
Case 2: 7

思路

一道并查集的题目,关键是要找到它的根节点。有N个人,先初始化数组是的值为数组的下标。
然后在输入每两个人之间的关系,开始更新数组的值,如果两个人的根节点的值相同,则不需要变化,如果不同,将第二个人的根节点的值更新为第一个根节点的值,只需要更新根节点,其他的子节点不需要更新。

代码

#include<cstdio>
int father[50005],sum;
int find(int x)
{
    if(father[x]!=x)
        father[x]=find(father[x]);
    return father[x];
}
void make(int a,int b)
{
    int root1=find(a);
    int root2=find(b);
    if(root1!=root2)
    {
        father[root2]=root1;
        sum--;
    }
}
int main()
{
    int h=1;
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(n==0&&m==0)break;
        for(int k = 1;k <= n;k ++)
            father[k] = k ;
        sum=n;
        for(int k = 1;k <= m;k ++)
        {
            int i,j;
            scanf("%d %d",&i,&j);
            make(i,j);
        }
    //    for(int k = 1; k <= n; k ++)
    //        printf("%d   ",father[k]);
        printf("Case %d: %d\n",h++,sum);

    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值