POJ 1308-Is It A Tree?(并查集)

Is It A Tree?
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 32343 Accepted: 10974

Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

There is exactly one node, called the root, to which no directed edges point. 
Every node except the root has exactly one edge pointing to it. 
There is a unique sequence of directed edges from the root to each node. 
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not. 

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

Source


题目意思:

给出若干组(a,b)表示一条有向边的起终点,求这些点能否构成一棵树。

解题思路:

①一棵树只有一个根结点;
②除了根节点以外的每一个节点都只有一条边指向它;
③不能出现环。
合并时注意:若b连到a上,则b要是根节点;同一棵树的两点不能再次合并。
用并查集对上述操作检验,合法操作合并,最后统计出现过的节点中构成的根节点数量。

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <iomanip>
#include <map>
#include <ctime>
#define INF 0x3f3f3f3f
#define MAXN 110
using namespace std;
int fa[MAXN];
bool vis[MAXN];
int fa_find(int p)
{
    if(fa[p]==p) return p;
    return fa[p]=fa_find(fa[p]);
}
bool join(int p,int q)
{
    int p1=fa_find(p);
    int q1=fa_find(q);
    if(q1!=q)  return true;//q不是根节点
    if(p1==q1) return true;//p和q已经在同一棵树
    else fa[q1]=p1;//合并两棵树
    return false;
}
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("G:/cbx/read.txt","r",stdin);
    //freopen("G:/cbx/out.txt","w",stdout);
#endif
    int n=0,a,b,ca=0,ans=0;
    for(int i=0; i<MAXN; ++i) fa[i]=i;
    memset(vis,false,sizeof(vis));
    while(~scanf("%d%d",&a,&b))
    {
        if(a==-1&&b==-1) break;
        if(a==0&&b==0)
        {
            int cnt=0;
            for(int i=0; i<n; i++)
            {
                if(fa[i]==i&&vis[i])//在出现过的节点中统计树根的数量
                    ++cnt;
                if(cnt>1) break;
            }
            if(cnt>1||ans>0)//多棵树或者出现过不合法的情况
                cout<<"Case "<<++ca<<" is not a tree."<<endl;
            else cout<<"Case "<<++ca<<" is a tree."<<endl;
            ans=0;//初始化
            for(int i=0; i<MAXN; ++i) fa[i]=i;
            memset(vis,false,sizeof(vis));
            continue;
        }
        n=max(n,a);
        n=max(n,b);//记录最大的序号
        vis[a]=vis[b]=true;//标记节点出现过
        if(join(a,b)) ++ans;//出现不合法情况
    }
    return 0;
}


Python网络爬虫与推荐算法新闻推荐平台:网络爬虫:通过Python实现新浪新闻的爬取,可爬取新闻页面上的标题、文本、图片、视频链接(保留排版) 推荐算法:权重衰减+标签推荐+区域推荐+热点推荐.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值