poj-1308-Is It A Tree?

Is It A Tree?

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point.
Every node except the root has exactly one edge pointing to it.
There is a unique sequence of directed edges from the root to each node.
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.
这里写图片描述
In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line “Case k is a tree.” or the line “Case k is not a tree.”, where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8 5 3 5 2 6 4
5 6 0 0

8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0

3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

思路一:

并查集,这个题和上一个小希的迷宫本质上是一样的道理,只不过需要注意一种特殊情况,就是结点自己指向自己不算数。我就是卡在了这里。
代码如下:

#include<iostream>
#include<cstring>
using namespace std;
int node[100100],book[100100];
int ma=100010,mi=0;
int getf(int v)
{
  if(node[v]==v)return v;
  else return node[v]=getf(node[v]);
}
int merge(int a,int b)
{
  int ta=getf(a);
  int tb=getf(b);
  if(ta==tb)return 1;
  else {node[tb]=ta;return 0;}
}
void init()
{
  for(int i=1;i<=100000;i++)node[i]=i;
}
void biaoji(int a,int b)
{
  if(a>ma) ma=a;
  if(b>ma) ma=b;
  if(a<mi) mi=a;
  if(b<mi) mi=b;
}
int main()
{
  int a,b,num=0;
  while(cin>>a>>b&&a!=-1&&b!=-1)
  {
    num++;
    init();
    memset(book,0,sizeof(book));
    if(!a&&!b)
    {
      cout<<"Case "<<num<<" is a tree."<<endl;
      continue;
    }
    book[a]=book[b]=1;
    biaoji(a,b);
    bool flag=true;
    merge(a,b);
    int x,y;
    while(cin>>x>>y&&x&&y)
    {
      book[x]=book[y]=1;
      biaoji(a,b);//确定最大编号和最小编号
      if(merge(x,y))flag=false;
    }
    int sum=0;//集合的数量
    for(int i=mi;i<=ma;i++)
    {
      if(book[i])
      {
        if(getf(i)==i)sum++;
      }
    }
    if(flag&&sum==1&&a!=b)cout<<"Case "<<num<<" is a tree."<<endl;//集合只有一个
    else cout<<"Case "<<num<<" is not a tree."<<endl;
  }
}

思路二:

直接利用树的性质,结点的数量是边的数量+1。
代码如下:

#include<iostream>
#include<cstring>
using namespace std;
int book[100010],ma=100010,mi=0;
void judge(int a,int b)
{
  if(a>ma) ma=a;
  if(b>ma) ma=b;
  if(a<mi) mi=a;
  if(b<mi) mi=b;
}
int main()
{
  int a,b,num=0;
  while(cin>>a>>b&&a>=0&&b>=0)
  {
    memset(book,0,sizeof(book));
    int node=0,edge=1;
    num++;
    book[a]=book[b]=1;
    if(!a&&!b)
    {
      cout<<"Case "<<num<<" is a tree."<<endl;
      continue;
    }
    judge(a,b);
    while(cin>>a>>b&&a&&b)
    {
      edge++;//统计边的数量
      book[a]=book[b]=1;
      judge(a,b);
    }
    for(int i=mi;i<=ma;i++)
    {
      if(book[i])node++;//统计结点数量
    }
    if(node==edge+1)cout<<"Case "<<num<<" is a tree."<<endl;
    else cout<<"Case "<<num<<" is not a tree."<<endl;
  }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值