POJ-1308-Is It A Tree?(并查集)

E - Is It A Tree?
Time Limit:1000MS Memory Limit:10000KB 64bit IO Format:%I64d & %I64u
Submit

Status

Practice

POJ 1308
Description
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point.
Every node except the root has exactly one edge pointing to it.
There is a unique sequence of directed edges from the root to each node.
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.
Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
Output
For each test case display the line “Case k is a tree.” or the line “Case k is not a tree.”, where k corresponds to the test case number (they are sequentially numbered starting with 1).
Sample Input
6 8 5 3 5 2 6 4
5 6 0 0

8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0

3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1
Sample Output
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

思路:每输入两个点都判断一下,这两个点连接以后会不会成为环,换句话说就是,判断一下合并之前,这两个点是不是同一个爹,如果还没合并,就是同一个爹了,那合并之后肯定成环,就不符合树的定义了。
所有数合并之后,遍历一遍所有输入的数,看看他们是不是都有一个共同的爹,否则那也不是树。

代码

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<math.h>
#include<string.h>
using namespace std;
const int maxn=105;
int Father[maxn];
void init()
{
    for(int i=1;i<=maxn;i++)
        Father[i]=i;
}
int Query(int x)
{
    if(x!=Father[x])
        Father[x]=Query(Father[x]);
    return Father[x];
}
void Merge(int x,int y)
{
    int flag_x=Query(x);
    int flag_y=Query(y);
    if(flag_x!=flag_y)
        Father[flag_x]=flag_y;
}
int main()
{
    int x,y;
    int flag=1;//不是树就标记为0
    int casen=1;
    int num[maxn];//初始化为0,存在此数标记为1
    memset(num,0,sizeof(num));
    init();
    while(scanf("%d%d",&x,&y))
    {
        if(x<0||y<0)
            break;
        if(x==0&&y==0)
        {
            int first=0;
            for(int i=1;i<maxn;i++)
            {
                if(num[i])
                {
                    first=i;
                    break;
                }
            }
            for(int i=1;i<maxn;i++)
            {
                if(num[i]&&first&&Query(first)!=Query(i))
                {
                    flag=0;
                    break;
                }
            }
            flag?printf("Case %d is a tree.\n",casen++):printf("Case %d is not a tree.\n",casen++);
            memset(num,0,sizeof(num));
            init();
            flag=1;
        }
        else//正常存储数字
        {
            num[x]=1;
            num[y]=1;
            if(Query(x)==Query(y))
                flag=0;//判环
            Merge(x,y);
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值