poj2318 Toys

29 篇文章 0 订阅
TOYS
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 10735 Accepted: 5169

Description

Calculate the number of toys that land in each bin of a partitioned toy box. 
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys. 

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box. 
 
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are "in" the box.

题意:一个箱子被n条线段分成了n+1份空间,问接下来有m个点,问这m个点分别在第几个空间里,没有在空间分割线上或者不在箱子内的情况,最后输出每份空间有多少个点。

题解:由于n条线段是按照顺序给出的,所以直接暴力枚举判断每个点是否是第一个空间,第二个空间or第三个空间...用判断点在直线的位置就行求解。叉积为正在直线左边,为负在直线右边,等于0在直线上。

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <cmath>
#include <queue>
#include <map>
#include <stack>
#include <list>
#include <vector>
#include <ctime>
#define LL __int64
#define eps 1e-8
using namespace std;
int ans[5200];
struct node
{
	int x1,x2;
}f[5200];
int across(int x1,int y1,int x2,int y2)
{
	return x1*y2-x2*y1; 
}
int main()
{
	int i,j,n,m,x1,y1,x2,y2,x,y;
	int ff=1;
	while (~scanf("%d",&n) && n)
	{
		if (ff) ff=0;
		else puts("");
		scanf("%d%d%d%d%d",&m,&x1,&y1,&x2,&y2);
		for (i=0;i<n;i++)
			scanf("%d%d",&f[i].x1,&f[i].x2);
		f[n].x1=x2;f[n].x2=x2;
		memset(ans,0,sizeof(ans));
		for (i=1;i<=m;i++)
		{
			scanf("%d%d",&x,&y);
			for (j=0;j<=n;j++)
			{
				int k=across(f[j].x1-x,y1-y,f[j].x2-x,y2-y);
				if (k<0){
					ans[j]++;
					break;
				}
			}
		}
		for (i=0;i<=n;i++)
			printf("%d: %d\n",i,ans[i]);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值