POJ 2318 TOYS (计算几何+叉积)

题面

Calculate the number of toys that land in each bin of a partitioned toy box.
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.

For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are "in" the box.

题目链接

POJ 2318

参考链接

百度文库:计算几何常用算法+直线拐点判断++线段相交判断

POJ 2318 TOYS (计算几何,叉积判断) Author:kuangbin 

题意理解

把m个玩具放在n+1个区域内,问每个区域各有多少个玩具?

做法

用差积判断点在线段的左侧或者右侧。

程序

#include<stdio.h>
#define maxn 5005
int ans[maxn];
int n;//隔板个数
int m;//toy个数
struct Point
{
    double x,y;
    Point(double X,double Y):x(X),y(Y){}
    Point(){};
    void change(double X,double Y){x=X,y=Y;}
}upper_left,lower_right,cardboard[maxn];

double cross(Point P,Point Q)
{
    return P.x*Q.y-P.y*Q.x;
}

void init()
{
    for(int i=0;i<=n;i++)
        ans[i]=0;
}

void read_cardboard()
{
    for(int i=1;i<=n;i++)
    {
        double x_up,x_down;
        scanf("%lf%lf",&x_up,&x_down);
        cardboard[i].change(x_up,x_down);
    }
    cardboard[n+1].change(lower_right.x,lower_right.x);
}

int find_position(Point t)
{
    int left,right,middle;
    left=0;
    right=n;
    int answer=-1;
    while(left<=right)
    {
        middle=(left+right)/2;
        Point P(t.x-cardboard[middle+1].y,t.y-lower_right.y);
        Point Q(cardboard[middle+1].x-cardboard[middle+1].y,upper_left.y-lower_right.y);
        double cross_ans=cross(P,Q);
        if(cross_ans<0)
        {
            answer=middle;
            right=middle-1;
        }
        else
            left=middle+1;
    }
    return answer;
}

int main()
{
    while(scanf("%d",&n)&&n)
    {
        init();
        scanf("%d%lf%lf%lf%lf",&m,&upper_left.x,&upper_left.y,&lower_right.x,&lower_right.y);
        read_cardboard();
        for(int e=1;e<=m;e++)
        {
            double x,y;
            scanf("%lf%lf",&x,&y);
            int which=find_position(Point(x,y));
            ans[which]++;
        }
        for(int i=0;i<=n;i++)
            printf("%d: %d\n",i,ans[i]);
        printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值