HDOJ 1018 Big Number

来源:http://acm.hdu.edu.cn/showproblem.php?pid=1018

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22074    Accepted Submission(s): 9946


Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10 7 on each line.
 

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 

Sample Input
  
  
2 10 20
 

Sample Output
  
  
7 19
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1013  1017  1016  1071  1003 

题意:这题就是要求一个数的阶乘结果的位数,比如输入5   由于5!=120  所以输出位数为3.

题解:这题就是利用个对数转换了下,很巧妙! log10(n!)=lg1+lg2+....lgn  这样题目就变得简单了。程序实现也很简单,在这里就不赘述了。

PS:开始我以为这题比大数阶乘还难,以为是要吧n! 计算出来再来统计位数,果断放弃了。 后来去网上找题解才知道这题根本没有那么麻烦来多行啊的代码就可以搞定。就是用了一个对数,不过我知道我自己肯定不会想到用对数来做的,自己跟本不知道math 头文件里面还包含了一个求对数的函数。 知道这点后,程序很快写好了,运行没有问题。但是第一次提交时杭电报错了!! 叫我把 log10(j)  中的j 改成double ,改完后就通过了。 但是并不知道为甚要这样,我想没必要去钻这些东西吧.

#include<iostream>
#include<cmath>
using namespace std;
int main() 
{
	int N,i,n;  double sum,j;
	cin>>N;
	for(i=0;i<N;i++){
		sum=1;
		cin>>n;
		for(j=1;j<=n;j++)
		sum+=log10(j);
		cout<<(int)sum<<endl;
	} 
	return 0;
}



 
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值