hdoj1018 Big Number//求数字位数

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 52992    Accepted Submission(s): 26078


 

Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.
 

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 

Sample Input
2
10
20
 

Sample Output
7
19

 求数字的位数可以用log10()函数来实现

log10()是一个cmath头文件里的函数  double log10(double x) 对数函数(10为底数)

数字位数=(int)log10(num)+1

放下代码!

这题记得要打表 不然会超时

#include<iostream>
#include<cmath>
int a[10000005];
int main()
{
    using namespace std;
    int T;
    __int64 x;
    double result=0;
    for(int i=1;i<=10000002;++i)
    {
        result+=log10(i);
        a[i]=(int)result+1;
    }
    cin>>T;
    while(T--)
    {
        result=0;
        cin>>x;
        cout<<a[x]<<endl;
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值