POJ 3517 And Then There Was One

题目链接:http://poj.org/problem?id=3517


And Then There Was One
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 4843 Accepted: 2576

Description

Let’s play a stone removing game.

Initially, n stones are arranged on a circle and numbered 1, …, n clockwise (Figure 1). You are also given two numbers k and m. From this state, remove stones one by one following the rules explained below, until only one remains. In step 1, remove stone m. In step 2, locate the k-th next stone clockwise from m and remove it. In subsequent steps, start from the slot of the stone removed in the last step, make khops clockwise on the remaining stones and remove the one you reach. In other words, skip (k − 1) remaining stones clockwise and remove the next one. Repeat this until only one stone is left and answer its number. For example, the answer for the case n = 8, k = 5, m = 3 is 1, as shown in Figure 1.


Initial state

Step 1

Step 2

Step 3

Step 4

Step 5

Step 6

Step 7

Final state
 
Figure 1: An example game

Initial state: Eight stones are arranged on a circle.

Step 1: Stone 3 is removed since m = 3.

Step 2: You start from the slot that was occupied by stone 3. You skip four stones 4, 5, 6 and 7 (since k = 5), and remove the next one, which is 8.

Step 3: You skip stones 1, 2, 4 and 5, and thus remove 6. Note that you only count stones that are still on the circle and ignore those already removed. Stone 3 is ignored in this case.

Steps 4–7: You continue until only one stone is left. Notice that in later steps when only a few stones remain, the same stone may be skipped multiple times. For example, stones 1 and 4 are skipped twice in step 7.

Final State: Finally, only one stone, 1, is on the circle. This is the final state, so the answer is 1.

Input

The input consists of multiple datasets each of which is formatted as follows.

n k m

The last dataset is followed by a line containing three zeros. Numbers in a line are separated by a single space. A dataset satisfies the following conditions.

2 ≤ n ≤ 10000, 1 ≤ k ≤ 10000, 1 ≤ m ≤ n

The number of datasets is less than 100.

Output

For each dataset, output a line containing the stone number left in the final state. No extra characters such as spaces should appear in the output.

Sample Input

8 5 3
100 9999 98
10000 10000 10000
0 0 0

Sample Output

1
93
2019

Source


题意: 略。

题解: 约瑟夫环~~ 最容易想的就是模拟,怎么说就怎么做,不过这题的数据量大,直接模拟肯定超时。
          so 找规律咯
就拿题目给的这种情况来说: n=8  k=5  m=3

初始状态: 1 2 3 4 5 6 7 8    

Step 1: 1 2 X 4 5 6 7 8  去掉第m个(也就是3)后重新编号(原来的4就变成1):   6 7 1 2 3 4 5  
             那么可以发现,重新编号的数字和以前的的编号有这么个关系: 假设现在的编号是x ,
             则以前的编号为(x+m)%n   
              比如x=1 ,则原来的编号为 (1+3)%8 == 4 说明现在的1是原来的4.
              同样的6 对应的是 (6+3)%8==1 (看下应该没错吧→_→)


Step 2:  6 7 1 2 3 4 X  去掉第k 个后重新编号(原来的6变成了 1) 1 2 3 4 5 6
            那么可以发现,重新编号的数字和以前的的编号有这么个关系: 假设现在的编号是x ,
             则以前的编号为(x+k)%(n-1)        
             比如x=1 ,则原来的编号为 (1+5)%7 == 6  说明现在的1是原来的6.  同样的6 对应的是 (6+5)%7==4  


Step 3: 1 2 3 4 X 6       去掉第k个 重新编号(原来的6 变成 1) 2 3 4 5 1
             那么可以发现,重新编号的数字和以前的的编号有这么个关系: 假设现在的编号是x ,
则以前的编号为(x+k)%(n-2)       
             比如x=1 ,则原来的编号为 (1+5)%6 == 0 (对于刚好整除的情况(余数为0),由于没有
            编号0,所以要看成余数为6)  说  明现在的1是原来的6.  同样的5 对应的是 (5+5)%6==4 


Step 4:  2 3 4 X 1   去掉第k个 重新编号(原来的1 变成 1)  2 3 4 1 
            那么可以发现,重新编号的数字和以前的的编号有这么个关系: 假设现在的编号是x ,
则以前的编号为(x+k)%(n-3)         
             比如x=1 ,则原来的编号为 (1+5)%5 ==1  说明现在的1是原 来的1.
             同样的4 对应的是 (4+5)%5==4 


Step 5:  2 3 4 X 去掉第k 个 重新编号(原来的2 变成 1) 1 2 3 
    那么可以发现,重新编号的数字 和以前的的编号有这么个关系: 假设现在的编号是x ,
            则以前的编号为(x+k)%(n-4)
           比如x=1 ,则原来的编号为 (1+5)%4 ==2 说明现在的1是原来的2. 
            同样的3 对应的是 (3+5)%5==3 


Step 6: 1 X 3  去掉第k 个 重新编号(原来的 2 变成 1)  2 1         
 那么可以发现,重新编号的数字和以前的的编号有这么个关系: 假设现在的编号是x ,
则以前的编号为(x+k)%(n-5)
            比如x=1 ,则原来的编号为 (1+5)%3 ==0(对于刚好整除的情况(余数为0),由于没有编号0,
             所以要看成余数为3)  说明  现在的1是原来的3.  同样的2 对应的是 (2+5)%3==1 


Step 7:   2 X  去掉第k 个 重新编号(原来的 2 变成 1)  1      
 那么可以发现,重新编号的数字和以前的的编号有这么个关系: 假设现在的编号是x ,
则以前的编号为(x+k)%(n-6)
            比如x=1 ,则原来的编号为 (1+5)%2 ==0(对于刚好整除的情况(余数为0),由于没有编号0,
            所以要看成余数为2)  说明 现在的1是原来的2. 


======================================================================================================
第一次这么详细的把分析过程写出来~~ 分析这种情况之后就可以推广到一般情况了。
可以倒着推回去。最后剩下的那个数的编号是1,那它之前的编号就应该是(1+k)%2  [这个2就是当前数字的个数+1] 当从倒数第二个Step反推
到倒数第一个Step 就不是 +k 而是+m 么,因为开始是去掉第m个。
======================================================================================================


注: X代码当前挖掉的那个位置
有了这个基础,那就可以用递归——(额,貌似应该叫递推吧~~) 解决之了~~
直接上代码:

AC代码:
#include<iostream>
using namespace std;
int n,m,k;
int Ring(int cnt,int num){
    int temp;
    if(cnt==n){
        temp=(num+m)%cnt;
        if(temp)return temp;
        else return cnt;
    }
    temp=(num+k)%cnt;
    if(!temp)temp=cnt;
    return Ring(cnt+1,temp);
}
int main()
{
    while(cin>>n>>k>>m&&(n||m||k)){
        cout<<Ring(2,1)<<endl;
    }
}

再贴一个超时的模拟代码

#include<iostream>
#define maxn 10000+5
using namespace std;
bool round[maxn];
int n,m,k,pos,cnt;
int main()
{
    cin.sync_with_stdio(false);
    while(cin>>n>>k>>m&&(m||k||n)){// 8 5 3
        cnt=n-1;
        for(int i=0;i<n;i++)round[i]=true;
        m=(m-1)%n;
        round[m]=false;
        pos=m;
        while(cnt){
            int tmpcnt=0;
            while(tmpcnt!=k){
                pos++;
                pos%=n;
                if(round[pos])tmpcnt++;
            }
            round[pos]=false;
            cnt--;
        }
        cout<<pos+1<<endl;
    }
    return 0;
}

哄哄,递归就是简洁~~ 大爱
【转载请注明出处】 MummyDing




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值