TOJ 2353.Reduced ID Numbers

题目链接:http://acm.tju.edu.cn/toj/showp2353.html



2353.    Reduced ID Numbers
Time Limit: 1.0 Seconds    Memory Limit: 65536K
Total Runs: 1755    Accepted Runs: 685



T.Chur teaches various groups of students at university U. Every U-student has a unique Student Identification Number (SIN). A SIN  s is an integer in the range 0 ≤  s≤ MaxSIN with MaxSIN = 10 6-1. T.Chur finds this range of SINs too large for identification within her groups. For each group, she wants to find the smallest positive integer  m, such that within the group all SINs reduced modulo  m are unique.

Input

On the first line of the input is a single positive integer N, telling the number of test cases (groups) to follow. Each case starts with one line containing the integer G (1 ≤ G ≤ 300): the number of students in the group. The following G lines each contain one SIN. The SINs within a group are distinct, though not necessarily sorted.

Output

For each test case, output one line containing the smallest modulus m, such that all SINs reduced modulo m are distinct.

Sample Input

2
1
124866
3
124866
111111
987651

Sample Output

1
8


Source: Northwestern European 2005
Submit   List    Runs   Forum   Statistics

暴力寻找,上代码

#include <stdio.h>
#include <string.h>
using namespace std;
int main(){
	int N,n,a[301];
	bool isa[1000001];
	scanf("%d",&N);
	while(N--){
		scanf("%d",&n);
		for(int i=0;i<n;i++)
			scanf("%d",&a[i]);
		int ans=1; 
		while(1){
			for(int i=0;i<ans;i++)
				isa[i]=false;
			bool flag=false;
			for(int i=0;i<n;i++){
				if(isa[a[i]%ans]==false)
					isa[a[i]%ans]=true;
				else{
					flag=true;
					break;
				}
			}
			if(flag){
				++ans;
				continue;
			}
			else{
				printf("%d\n",ans);
				break;
			}
		}	
	}
} 



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值