POJ---1273 Drainage Ditches【最大流】

Description

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50

SOURCE:点击打开链接


题意:

   赤裸裸的网络流题目。给定点数,边数,每条边的容量,以及源点,汇点,求最大流。

解析:

   通过Ford-Fulkerson算法或者是Dinic算法,通过dfs搜索最小流进行增广路。

Ford-Fulkerson算法:

#include <iostream>
#include <cstring>
#include <algorithm>
#define MAX 205
#define INF 0x7fffffff
using namespace std;

int n,m;
int c[MAX][MAX];
bool pass[MAX];
int dfs(int s,int t,int low);//s为源点,t为汇点,low为当前流
int dfs_max_flow(int s,int t);

int main(void)
{
    int a,b,d;
    while (cin>>n>>m)
    {
        memset(c,0,sizeof(c));
        for (int i=1; i<=n; ++i)
        {
            cin>>a>>b>>d;
            c[a][b]+=d;
        }
        cout<<dfs_max_flow(1,m)<<endl;
    }
    return 0;
}

int dfs(int s,int t,int low)
{
    if (s==t)
        return low;
    pass[s]=1;
    for (int i=1; i<=m; ++i)
    {
        if (!pass[i]&&c[s][i])
        {
            int flow=dfs(i,t,min(low,c[s][i]));
            if(flow>0)  //增广该路径
            {
                c[s][i]-=flow;
                c[i][s]+=flow;
                return flow;
            }
        }
    }
    return 0;
}

int dfs_max_flow(int s,int t)
{
    memset(pass,0,sizeof(pass));
    int maxflow=0,flow;
    while (flow=dfs(s,t,INF)) //不断地增广路径进行搜索,直到无法继续增加才结束
    {
        memset(pass,0,sizeof(pass));
        maxflow+=flow;
    }
    return maxflow;
}

Dinic算法:

#include<iostream>
#include<cstring>
#include<queue>
#define maxn 205
#define INF 0x7fffffff
using namespace std;

int n, m;
int c[maxn][maxn];
int dis[maxn];//dis[i]表示到原点s的层数

bool bfs();
int  dfs(const int x,const int low);

int main(void)
{
    int s,t,d;
    while(cin>>n>>m)
    {
        memset(c,0,sizeof(c));
        for(int i = 0  ; i < m; i++)
        {
            cin>>s>>t>>d;
            c[s][t] += d;
        }
        int ans = 0;
        int res;
        while(bfs())
            while(res = dfs(1,INF))
                ans+= res;
        cout<<ans<<endl;
    }
    return 0;
}

bool bfs()// 重新建图按层数建图
{
    memset(dis,-1,sizeof(dis));
    int k;
    dis[1] = 0;
    queue<int> que;
    que.push(1);
    while(que.size())
    {
        k = que.front();
        que.pop() ;
        for( int i = 1; i<= m; i++)
            if(c[k][i] > 0 && dis[i] < 0 )// 如果 可以  可以到达 但 还没有 访问
            {
                dis[i] = dis[k]+ 1;
                que.push(i);
            }
    }
    if(dis[n] > 0)
        return true;
    else
        return false;
}

int  dfs(const int x,const int low)// 查找路径上的最小的流量
{
    int flow;
    if(x == n)
        return low;
    for(int i = 1; i<= n; i++)
        if(c[x][i] > 0 && dis[i] == dis[x] + 1)
        {
            flow=dfs(i,min(low,c[x][i]));
            if(flow>0)
            {
                c[x][i] -= flow;
                c[i][x] += flow;
                return flow;
            }
        }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了小程序应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 适合毕业设计、课程设计作业。这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。 所有源码均经过严格测试,可以直接运行,可以放心下载使用。有任何使用问题欢迎随时与博主沟通,第一时间进行解答!
提供的源码资源涵盖了小程序应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 适合毕业设计、课程设计作业。这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。 所有源码均经过严格测试,可以直接运行,可以放心下载使用。有任何使用问题欢迎随时与博主沟通,第一时间进行解答!

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值