PAT_甲级_1065. A+B and C (64bit) (20)

题目链接:点击打开链接

 

Given three integers A, B and C in [-263, 263], you are supposed to tell whether A+B > C.

Input Specification:

The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line "Case #X: true" if A+B>C, or "Case #X: false" otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

我的python2程序:

 

n=int(raw_input())
num=[]
for i in range(1,n+1):
    num=[int(j) for j in raw_input().split()]
    if num[0]+num[1]>num[2]:
        print "Case #%d: true"%(i)
    else:
        print "Case #%d: false"%(i)

 

=======

 

2015.7.13

java

 

import java.util.*;
import static java.lang.System.*;
import java.math.*;
public class Main
{
	public static void main(String[] args)
	{
		Scanner cin=new Scanner(System.in);
		BigInteger a=BigInteger.valueOf(1);
		BigInteger b=BigInteger.valueOf(1);
		BigInteger c=BigInteger.valueOf(1);
		int n=0;
		n=cin.nextInt();
		for(int i=0;i<n;i++)
		{
			a=cin.nextBigInteger();//输入大数字a
			b=cin.nextBigInteger();//输入大数字b
			c=cin.nextBigInteger();//输入大数字c
			a=a.add(b);//a=a+b;
			if(a.compareTo(c)>0)
			{
				System.out.println("Case #"+(i+1)+": true");
			}
			else
			{
				System.out.println("Case #"+(i+1)+": false");
			}
		}
	}
}

 

 

 

 

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值