7-1 Pop Sequence (25 分)

7-1 Pop Sequence (25 分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

作者: 陈越

单位: 浙江大学

时间限制: 400 ms

内存限制: 64 MB

代码长度限制: 16 KB

 

该题目就是要求1到N依次入栈,出栈随机,而得到与输入相同的队列,如果能得到,则输出YES,否则输出ERROR

#include <iostream>
#include <cstdio>
using namespace std;

int main(int argc, const char * argv[]) {
    int M,N,K;
    scanf("%d %d %d",&M,&N,&K); //M为栈的最大值,N为输出的队列长度,K为测试样例个数
    for (int i=0; i<K; i++) {//循环k次,分别检查是否能通过出栈,入栈完成
        int a[N],b[N];//a[N]保存输入的样例,b[N]模拟栈
        for (int j=0; j<N; j++) {
            scanf("%d",&a[j]);
        }
        int top=0,ptr=0,instack=1;//top为b[N]的栈顶指针,ptr为检索a[N]当前的数据位置,instack为依次入队的自然数据
        while (ptr<N) { //检查是否检索完a[N]
            if (instack==a[ptr]&&top<M) {
                ptr++;
                instack++;
            }//如果入队的自然数据等于当前检索的样例的a[ptr]值,且栈未满,即可通过入栈再出栈完成当前数字pop
            else if(top>0&&b[top]==a[ptr]){
                top--;
                ptr++;
            }//如果栈顶数字等于检索样例a[ptr]的值,则可出栈
            else if(top<M-1&&ptr<N){
                b[++top]=instack;
                instack++;
            }//若栈未满,且未完成此组扫描,则入栈
            else break;//其他情况则推出循环
        }
        if (ptr<N) printf("NO\n");
        else printf("YES\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值