PAT甲级-A1065.A+B and C

题目:1065 A+B and C (64bit) (20 分)

Given three integers A, B and C in [−2​63​​,2​63​​], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

 

注意事项以及代码:

本题需要注意long long型数据的范围是[-2^63,2^63),因此题目中给出的两个整数相加有可能会溢出!!

因此直接进行大小的判断会出现错误。而计算机组成原理中说到:当两个正数之和等于负数或是两个负数之和等于正数,那么就是溢出。

因此给出代码如下:

#include <cstdio>

int main()
{
    int  T,flag;
    long long A, B, C;
    scanf("%d", &T);
    for (int i = 1; i <=T; i++) {
        scanf("%lld%lld%lld", &A, &B, &C);
        long long res = A + B;
        if (A > 0 && B > 0 && res < 0) flag = true;
        else if (A < 0 && B < 0 && res >= 0) flag = false;
        else if (A + B > C) flag = true;
        else {
            flag = false;
        }
        if (flag==true) {
            printf("Case #%d: true\n", i);
        }
        else {
            printf("Case #%d: false\n", i);
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值