A - Wireless Network 并查集+路径压缩

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.
Input
The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. “O p” (1 <= p <= N), which means repairing computer p.
2. “S p q” (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.
Output
For each Testing operation, print “SUCCESS” if the two computers can communicate, or “FAIL” if not.
Sample Input
4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4
Sample Output
FAIL
SUCCESS

题解:

并查集+路径压缩的经典应用。
自己想了一会儿,没什么思路。还是对并查集的应用不熟悉。
思路:
用一个vector保存已经修复好的computer。
每次修复好一个computer,就扫一遍vector数组,并计算距离,如果距离满足要求,则unite两个computer.
判断是否两个computer是否连接的话,判断他俩的根是否相等即可。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
#include <cmath>
using namespace std;
const int maxn = 1010;

int dx[maxn],dy[maxn];
int par[maxn];
int rank[maxn];
vector<int> repair;
int N,d;

void init()
{

    for(int i=1;i<=N;i++)
    {
        par[i]=i;
        rank[i]=0;
    }
}

int find(int x)
{
    if(par[x]==x)
    {
        return x;
    }
    else
    {
       return par[x] = find(par[x]);
    }
}

void unite(int x,int y)
{
    x = find(x);
    y = find(y);
    if(x==y) return;
    if(rank[x]<rank[y])
        par[x]=y;
    else
    {
         par[y]=x;

       if(rank[x]==rank[y])
        rank[x]++;
    }
}



double dist(int i,int j)
{
    return sqrt(double((dx[i]-dx[j])*(dx[i]-dx[j])+(dy[i]-dy[j])*(dy[i]-dy[j])));
}

int main()
{

    scanf("%d%d",&N,&d);
    init();

    for(int i=1;i<=N;i++)
    {
       scanf("%d%d",&dx[i],&dy[i]);
    }

    char op;
    int p;

    while(cin>>op)
    {
        switch(op)
        {
           case 'O':
              {
                  scanf("%d",&p);

                  repair.push_back(p);

                  for(int i=0;i<repair.size();i++)
                  {
                      if(repair[i]!=p&&dist(repair[i],p)<=(double)d)
                      {

                          unite(repair[i],p);

                      }
                  }

                  break;
              }

           case 'S':
              {
                  int a,b;
                  scanf("%d%d",&a,&b);

                  if(find(a)==find(b))
                  {
                      printf("SUCCESS\n");
                  }
                  else
                  {
                      printf("FAIL\n");
                  }

              }
            default:
            break;
        }
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值