G - Arctic Network(最小生成树的第K大边)

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel.
Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts.

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.
Input
The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).
Output
For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.
Sample Input
1
2 4
0 100
0 300
0 600
150 750
Sample Output
212.13

题意:

要在n个节点之间建立通信网络,其中m个节点可以用卫星直接连接,剩下的节点都要用线路连接,求剩下这些线路中最大的长度需要多长
明显还是最小生成树的题

题解:

如果用Prime算法,该算法现在V1集合中放入任意一个节点,然后每次选取和V1集合中的节点相连的最短的边的另一个节点加入到V1集合。
此时,可以把建成整棵最小生成树的所有边记录在一个数组里,然后排序,dist[n-m]就是答案

如果是kruskal算法,该算法每次选取最短的边,只需选完n-m条边就能得到答案

Kruskal代码:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdio>
using namespace std;

const int maxn = 550;
const int maxm = 300000;

int F[maxn];
int dist[maxn];
int n,m;

struct Node
{
    double x,y;
}MAP[maxn];

double Dis(Node a,Node b)
{
    return sqrt((a.x - b.x)*(a.x - b.x) + (a.y-b.y)*(a.y-b.y)) ;
}

struct Edge
{
    int u;
    int v;
    double w;
}edge[maxm];

int tol;

bool cmp(Edge a,Edge b)
{
    return a.w<b.w;
}

int find(int x)
{
    if(F[x]==x) return x;
    else return F[x]=find(F[x]);
}

double Kruskal(int n)
{
    for(int i=0;i<=n;i++) F[i]=i;

    sort(edge,edge+tol,cmp);

    int cnt=0;
    double ans=0;
    for(int i=0;i<tol;i++)
    {
        int u = edge[i].u;
        int v = edge[i].v;
        double w = edge[i].w;
        int tOne = find(u);
        int tTwo = find(v);
        if(tOne!=tTwo)
        {
            ans += w;
            F[tOne]=tTwo;
            cnt++;
        }
        if(cnt==n-m)
        {
            return w;
        }
    }

}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        tol=0;
        scanf("%d%d",&m,&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%lf%lf",&MAP[i].x,&MAP[i].y);
        }
        for(int i=1;i<n;i++)
        {
            for(int j=i+1;j<=n;j++)
            {
                edge[tol].u=i;
                edge[tol].v=j;
                edge[tol].w=Dis(MAP[i],MAP[j]);
                tol++;
            }
        }
        double ans = Kruskal(n);
        printf("%.2lf\n",ans);

    }
    return 0;
}

Prim代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;

const int INF = 0x3f3f3f3f;
const int maxn = 550;
int n,sum;
bool visit[maxn];
double cost[maxn][maxn];
double lowc[maxn];
double dist[maxn];

struct Node
{
    double x,y;
}MAP[maxn];

double Dis(Node a,Node b)
{
    return sqrt((a.x - b.x)*(a.x - b.x) + (a.y-b.y)*(a.y-b.y)) ;
}

void init()
{
    double temp;
    for(int i=1;i<=n;i++) cost[i][i]=INF;
    for(int i=1;i<=n;i++)
    {
        for(int j=i+1;j<=n;j++)
        {
            temp = Dis(MAP[i],MAP[j]);
            cost[i][j]=cost[j][i]=temp;
        }
    }
}

void Prim()
{
    int cnt=0;
    memset(visit,false,sizeof(visit));
    visit[1]=true;
    for(int i=1;i<=n;i++) lowc[i]=cost[1][i];
    lowc[1]=0;
    for(int i=1;i<n;i++)
    {
        double minc = INF;
        int p = -1;
        for(int j=1;j<=n;j++)
        {
            if(!visit[j]&&minc>lowc[j])
            {
                minc = lowc[j];
                p = j;
            }
        }
        visit[p]=true;
        dist[cnt++]=minc;
        for(int j=1;j<=n;j++)
        {
           if(lowc[j]>cost[p][j])
           {
               lowc[j]=cost[p][j];
           }
        }
    }
    sort(dist,dist+cnt);
    printf("%.2f\n",dist[cnt-sum]) ;
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&sum,&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%lf%lf",&MAP[i].x,&MAP[i].y);
        }
        init();
        Prim();
    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值