Light OJ 1008 Fibsieve`s Fantabulous Birthday(找出数字位置)

Fibsieve had a fantabulous (yes, it's an actual word) birthday party this year. He had so many gifts that he was actually thinking of not having a party next year.

Among these gifts there was an N x N glass chessboard that had a light in each of its cells. When the board was turned on a distinct cell would light up every second, and then go dark.

The cells would light up in the sequence shown in the diagram. Each cell is marked with the second in which it would light up.

10111213
98714
23615
14516

(The numbers in the grids stand for the time when the corresponding cell lights up)

In the first second the light at cell (1, 1) would be on. And in the 5th second the cell (3, 1) would be on. Now, Fibsieve is trying to predict which cell will light up at a certain time (given in seconds). Assume thatN is large enough.

Input

Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case will contain an integer S (1 ≤ S ≤ 1015) which stands for the time.

Output

For each case you have to print the case number and two numbers (x, y), the column and the row number.

Sample Input

3

8

20

25

Sample Output

Case 1: 2 3

Case 2: 5 4

Case 3: 1 5

题解:

数字按图分布,给出任意数字,写出其数字坐标:

1:

判断n是否为一个数的平方,若是,求出这个数z;

若z为奇数则(z,1),若是偶数,则(1,z);

2:

若不能开方,则m=z+1;,n必在第m列,或第m行;

若m为奇数判断m*m-n是否小于m,若不小于则x=m,y=n-(m-1)*(m-1),反之y=m;x=m*m-n+1;

若m为偶数,判断m*m-n是否小于m,若不小于,则x=m*m-n+1,y=m,反之x=m;y=n-(m-1)*(m-1);

代码:

#include<stdio.h>
#include<math.h>  
int main()  
{  long long t,n,x,y,z,m;
int k=1; 
    scanf("%d",&t);  
 while(t--)  
    {  
      scanf("%lld",&n);  
      z=sqrt(n);  
      if(z*z==n)
	   {
   		if(z%2==0)
  	  printf("Case %d: %lld 1\n",k++,z); 
  	  else  
		printf("Case %d: 1 %lld\n",k++,z);
		continue; 
   	}  
      else
	  {m=z+1;  
      if(m%2==1)
	  {  
        if(m*m-n<m)
		{  
            y=m;
			x=m*m-n+1;  
        }  
        else{  
            x=m;
			y=n-(m-1)*(m-1);  
        }}  
     else{  
        if(m*m-n<m)
		{  
            x=m;
			y=m*m-n+1;  
        }  
        else{  
            y=m;x=n-(m-1)*(m-1);  
        }  
     }  
     printf("Case %d: %lld %lld\n",k++,x,y);  
      } } 
 
   
}  




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值