LightOJ1008 Fibsieve`s Fantabulous Birthday(规律+基础数学)

Fibsieve had a fantabulous (yes, it's an actual word) birthday party this year. He had so many gifts that he was actually thinking of not having a party next year.

Among these gifts there was an N x N glass chessboard that had a light in each of its cells. When the board was turned on a distinct cell would light up every second, and then go dark.

The cells would light up in the sequence shown in the diagram. Each cell is marked with the second in which it would light up.

(The numbers in the grids stand for the time when the corresponding cell lights up)

In the first second the light at cell (1, 1) would be on. And in the 5th second the cell (3, 1) would be on. Now, Fibsieve is trying to predict which cell will light up at a certain time (given in seconds). Assume that N is large enough.

Input

Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case will contain an integer S (1 ≤ S ≤ 1015) which stands for the time.

Output

For each case you have to print the case number and two numbers (x, y), the column and the row number.

Sample Input

3

8

20

25

Sample Output

Case 1: 2 3

Case 2: 5 4

Case 3: 1 5

题意:就是按照上面那个表的规律,给出一个数字,输出这个数字对应的坐标。

题解:其实上面那个图按照那个排列顺序是有规律的。

           x=1的这一列 1 9 25 都是奇数的平方而且开方后正是这个数的列数。
           y=1的这一行,1 4 16都是偶数的平方,而且开方后正是这个数的行数。
           观察对角线的数,1 3 7 13 21… 设列数为a 每列的对角线数都等于a*(a-1)+1。

现在我们将给出的n开方,定义为x,

           1.x*x=n:要是x为奇数,他的坐标一定是(1,x),反之为(x,1)。

           2.x*x!=n:因为我们在开方时,都是取得整数,算出来的行或者列都是前面的那一行或列,所以实际数字在的行或列为x+1,至于x+1是行数还是列数,我们就要对x分奇偶讨论了,我们将对角线的值定义为y,y=(x+1)*x+1。

当x+1为奇数:(1)y>n时x+1则为列数,行数就是x+1减去y到n的距离:(x+1-(n-y),x+1);

                        (2)y<n时x+1为行数,列数与y>n时行数情况一样:(x+1,x+1-(y-n));

当x+1为偶数:讨论方法和x+1为奇数时一样。

#include <iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<map>
#include<queue>
#include<set>
#include<cmath>
#include<stack>
#include<string>
const int maxn=1e5+10;
const int mod=1e9+7;
const int inf=1e8;
#define me(a,b) memset(a,b,sizeof(a))
#define lowbit(x) x&(-x)
#define mid l+(r-l)/2
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
#define PI 3.14159265358979323846
int dir[4][2]= {0,-1,-1,0,0,1,1,0};
typedef long long ll;
using namespace std;
int main()
{
    int t,Case=1;
    scanf("%d",&t);
    while(t--)
    {
        ll n;
        scanf("%lld",&n);
        ll x=sqrt(n);
        printf("Case %d: ",Case++);
        if(x*x==n)///特殊情况
        {
            if(x&1)
                printf("1 %lld\n",x);
            else
                printf("%lld 1\n",x);
        }
        else
        {
            ll y=(x+1)*x+1;
            if((x+1)&1)
            {
                if(n>y)
                    printf("%lld %lld\n",x+1-(n-y),x+1);
                else
                    printf("%lld %lld\n",x+1,x+1-(y-n));
            }
            else
            {
                if(n>y)
                    printf("%lld %lld\n",x+1,x+1-(n-y));
                else
                    printf("%lld %lld\n",x+1-(y-n),x+1);
            }
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值