HDU 4004 The Frog's Games(二分)

The Frog's Games
Time Limit:1000MS     Memory Limit:65768KB     64bit IO Format:%I64d & %I64u

Description

The annual Games in frogs' kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they 
are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog's longest jump distance).
 

Input

The input contains several cases. The first line of each case contains three positive integer L, n, and m. 
Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.
 

Output

For each case, output a integer standing for the frog's ability at least they should have.
 

Sample Input

      
      
6 1 2 2 25 3 3 11 2 18
 

Sample Output

      
      
4 11
给出一条河宽l,河中有n个石头,问在最多跳m下的情况下,每次跳的最长距离的最小值是多少
因为青蛙的跳跃能力越强需要的次数就越少,因此青蛙的跳跃能力有单调性,所以二分枚举青蛙的跳跃能力,在判断这个能力下是否能够跳过去,这个用贪心解决,每次在这个能力下尽可能跳到远的石头上,最后看m次是否跳到了对岸。
#include<iostream>  
#include<cstdio>  
#include<cstring>  
#include<iostream>  
#include<algorithm>  
using namespace std;  
int a[500005];  
int main()  
{  
    int l,ll,n,m,max,sum;  
    int i,j,cont,t;  
    while(~scanf("%d%d%d",&l,&n,&m))  
    {  
        max=0;sum=0;  
        memset(a,0,sizeof(a));  
        for(i=1;i<=n;i++)  
            scanf("%d",&a[i]); 
			a[n+1]=l; 
        sort(a,a+n+2);  
            for(i=1;i<=n+1;i++)  
        {  
            if(a[i]-a[i-1]>max)  
                max=a[i]-a[i-1];  
        }   //找出两石头间最长的距离
  
        for(j=max;j<=l;j++)//枚举
        {  
  
            i=1;cont=1;t=0;ll=l;  
            while(ll>0&&i<=n+1)  
            {  
                ll-=a[i]-a[i-1];  
                if(a[i]-t>j)  
                {cont++;t=a[i-1];}  
                
                i++;  
            }  
            if(cont<=m)  
                break; 
        }  
        printf("%d\n",j);  
    }  
    return 0;  
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值