二分法(分蛋糕)

Pie
Time Limit:1000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u

Description

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
 

Input

One line with a positive integer: the number of test cases. Then for each test case:
---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.
 

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
 

Sample Input

       
       
3 3 3 4 3 3 1 24 5 10 5 1 4 2 3 4 5 6 5 4 2
 

Sample Output

       
       
25.1327 3.1416 50.2655

题目大意:
某人要过生日,共有n个蛋糕,邀请s个人,给出每个蛋糕的半径,平均将蛋糕分给所有人(包括自己),所分蛋糕不能拼凑,求可以平均分到的最大蛋糕。
题解:
先对所有蛋糕进行快排,从小到大,然后在0和最大蛋糕体积之间进行二分,直到满足题意:
代码:
<pre name="code" class="cpp">#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<math.h>
using namespace std;
#define kll acos(-1.0)
double t,f,a[100000],l,e,sum,h;
int n,m;
int erfen(double mid)
{
int i;
int sum=0;
for(int i=0;i<n;i++)
sum+=(int(a[i]/mid));
if(sum>=m+1)
return 1;
else
return 0;	
}
int main()
{
scanf("%lf",&t);
while(t--)
{sum=0;
	scanf("%d%d",&n,&m);
	for(int i=0;i<n;i++)
	{scanf("%lf",&a[i]);
	a[i]=a[i]*a[i]*kll;}
	sort(a,a+n);
l=0;e=a[n-1];
while(e-l>0.0000001)
{
	h=(l+e)/2;
	if(erfen(h))
	l=h;
	else
	e=h;
}
printf("%.4lf\n",l);
	
	
}
	
}




 
  
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值