Red packet 二分

Red packet
Time Limit:1000MS     Memory Limit:65535KB     64bit IO Format:%lld & %llu

Description

New Year is coming! Our big boss Wine93 will distribute some “Red Package”, just like Alipay and Wechat.

Wine93 has m yuan, he decides to distribute them to n people and everyone can get some money(0 yuan is not allowed and everyone’s money is an integer), Now k people has gotten money, it’s your turn to get “Red Package”, you want to know, at least how much money to give you, then you can must become the “lucky man”. and the m yuan must be used out.

Noting that if someone’s money is strictly much than others’, than he is “lucky man”.


Input

Input starts with an integer T (T <= 50) denoting the number of test case. 
For each test case, three integers n, m, k (1 <= k < n <= 100000, 0< m <= 100000000) will be given. 
Next line contains k integers, denoting the money that k people get. You can assume that the k integers’ summation is no more than m. 

Output

Ouput the least money that you need to become the “lucky man”, if it is impossible, output “Impossible” (no quote). 

Sample Input

3
3 5 2
2 1
4 10 2
2 3
4 15 2
3 5

Sample Output

Impossible
4
6
给出t组数据,每组数据包括要发红包总人数n,总钱数m,已发人数,问自己至少得多少钱,才能成为幸运者,幸运者的钱数是最多的
#include<stdio.h>
#include<algorithm>
#include<iostream>
using namespace std;
int main()
{
	int n,m,t,k,a;
	scanf("%d",&t);
	while(t--)
	{int sum=0,sum1=0;
		scanf("%d%d%d",&n,&m,&k);
		for(int i=0;i<k;i++)
		{scanf("%d",&a);
		sum=max(sum,a);
		sum1+=a;}
		int t1=m-sum1;//发了k人还剩多少钱
		int t2=n-k;//还有多少人没发
		if(t1<=n-k||t1-t2+1<=sum)//不可能成为幸运者的条件
		{
			printf("Impossible\n");
			continue;
		}
		int r=t1,l=sum+1,mid,ans=0;
		while(r>=l)//二分
		{
			mid=(r+l)/2;

			if(mid>sum&&(t1-mid-t2+2)<mid)
			{
				r=mid-1;
				ans=mid;
				
			}
			else
			l=mid+1;
		}
		printf("%d\n",ans);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值