poj 1426 Find The Multiple ( dfs )

点击打开链接


Find The Multiple
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 22234 Accepted: 9128 Special Judge

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

Source


题目大意:
就是给你一个数 m,让你找只含有 0 和 1 的数而且是 m 的倍数的数

解题思路:
从网上看到的说最大的数不会超过18位,(m<=200),所以,可以直接用无符号位的数就行了,不涉及大数问题,
直接上dfs搞一下子,就行了,具体详见我代码:
/*
2015 - 09 - 09


Author: ITAK


Motto:
今日的我要超越昨日的我,明日的我要胜过今日的我,
以创作出更好的代码为目标,不断地超越自己。
*/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>


using namespace std;
bool ok;


/// t:表示0和1组成的数, k:位数,m:给定的数
void dfs(unsigned long long t, int k, int m)
{
    if(ok)///退出的标志
        return;
    if(t%m == 0)
    {
        cout<<t<<endl;
        ok = 1;
        return;
    }
    if(k == 19)
        return;
    dfs(t*10, k+1, m);///有可能是0
    dfs(t*10+1, k+1, m);///有可能是1
}


int main()
{
    int m;
    while(cin>>m,m)
    {
        ok = 0;
        dfs(1, 0, m);///从1开始搜,因为最高位是1
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值