POJ1426 Find The Multiple(DFS)

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

这道题大意就是输入一个n,然后求n的倍数,但是这个倍数只能由0或1构成。因为这个代码有借鉴他人的,加了小编的一点思想,在这里详细解释一下

#include<iostream>
#include<cstdio>
using namespace std;
bool  found;

void dfs(long long k,int n,int m)
{
	if (found)   return;
	if (k%n == 0)
	{
		printf("%lld\n", k);
		found = 1;
		return;
	}
	if (m == 18)    return;
	else
	{
		dfs(k * 10,n,m+1);
		dfs(k * 10 + 1,n,m+1);
	}
}
int main()
{
	int n;
	while (cin>>n,n)
	{
		found = 0;
		 dfs(1,n,0);
	}
	return 0;
}
这个代码首先第一点要加一个判断bool类型的作为最后输出,因为找到了结果就没有再找下去的必要了。然后有另一点注意的是,要大致算一下范围,long long类型范围大小是-2^63 到 2^63-1,代码中dfs必须要有两种清况,就是如果第一个dfs找不到结果会进行第二个dfs,所以必须加一个上限,就是乘到第18层的时候就得跳有一个跳出条件,从而执行第二个dfs.

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值