POJ 3071 Football(概率DP)

传送门

Football
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 4366
Accepted: 2231

Description

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then, the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n rounds, only one team remains undefeated; this team is declared the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2n values; here, the jth value on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 − pji for all i ≠ j, and pii = 0.0 for all i. The end-of-file is denoted by a single line containing the number −1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the double data type instead of float.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least 0.01.

Sample Input

2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1

Sample Output

2

Hint

In the test case above, teams 1 and 2 and teams 3 and 4 play against each other in the first round; the winners of each match then play to determine the winner of the tournament. The probability that team 2 wins the tournament in this case is:

P(2 wins) P(2 beats 1)P(3 beats 4)P(2 beats 3) + P(2 beats 1)P(4 beats 3)P(2 beats 4)
p21p34p23 + p21p43p24
= 0.9 · 0.6 · 0.4 + 0.9 · 0.4 · 0.5 = 0.396.

The next most likely team to win is team 3, with a 0.372 probability of winning the tournament.

Source


题目大意:
给定一个数 n ,有2 ^n 个队伍进行比赛,然后再给定 2^n * 2^n 的矩阵 p[ i ][ j ]表示的是 team i 赢 team j 的概率,比赛的顺序是连续的,就是:0和1比 2和3 比...让你求的是 最后胜利的概率最大的队伍是哪一个?


解题思路:

通过这个题我们很容易想到的就是用 DP来做,DP[ i ][ j ] 表示的就是第 i 场比赛 第 j 个人赢的概率,DP[ 0 ][ j ] = 1,那么如果要取得最后的胜利,因为他们是两两进行比赛,所以 一共就采用 n 场就能决出最后的冠军,所以我们很容易就写出外层循环 for(i: 1-n ),这个表示的 n 场比赛,那么这层循环里面 应该是 两个人进行比赛,所以有两个循环,for(j : 0-2^n-1) ,for(k; 0-2^n-1);那么我们遇到一个问题了,就是j 和 k 到底是在什么情况下进行的比赛呢,只要弄明白这个了 一切就非常完美了,那么我们可以画一下(拿n==3为例):

第 i 场比赛:比赛队伍

第一场比赛:(0和1) (1和0),(2和3)  (3和2),(4和5) (5和4),(6和7)  (7和6);

第二场比赛:(0和2) (0和3),(1和2) (1和3),(2和0)  (2和1),(3和0)  (3和1),(4和6) (4和7),(5和6) (5和7),(6和4) (6和5),(7和4) (7和5);

....

总而言之 我们可以发现这样一个规律:(其实这个规律也不是自己发现的 也是看网上的大牛的博客,但是大牛们没有给出为什么来的,在这里我就写了一点,写的不好请见谅,这个规律就是 这个题的中心!!!)

就是当 ( j>>(i-1) )^1 与 ( k>>(i-1) )相等的时候, j 和 k 就能进行比赛。所以DP[ i ][ j ] += DP[ i-1 ][ j ] * DP[ i-1 ][ k ] * p[ j ][ k ];  // 在第 i 场比赛中 j 赢了 k

My Code:

<span style="font-size:18px;">#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
double mat[1000][1000];
double dp[10][1000];///dp[i][j]表示第i场比赛 j赢的概率
int main()
{
    int n;
    while(cin>>n)
    {
        if(n == -1)
            break;
        for(int i=0; i<(1<<n); i++)
            for(int j=0; j<(1<<n); j++)
                scanf("%lf",&mat[i][j]);
        memset(dp, 0, sizeof(dp));
        for(int i=0; i<(1<<n); i++)
            dp[0][i] = 1.0;
        for(int i=1; i<=n; i++)///n场比赛
        {
            for(int j=0; j<(1<<n); j++)
            {
                for(int k=0; k<(1<<n); k++)
                {
                    if(((j>>(i-1))^1)==(k>>(i-1)))///关键!!第i场比赛:j和k进行比赛
                    {
                        dp[i][j] += dp[i-1][j]*dp[i-1][k]*mat[j][k];
                    }
                }
            }
        }
        int rating = 0;///记录的第几个人赢的概率最大
        double Max = -9999;
        for(int i=0; i<(1<<n); i++)
        {
            if(Max < dp[n][i])
            {
                rating = i;
                Max = dp[n][i];
            }
        }
        cout<<rating+1<<endl;
    }
    return 0;
}
</span>


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值