HDU 5908 Abelian Period(map + 思想)——BestCoder Round #88

227 篇文章 0 订阅
97 篇文章 0 订阅

传送门

Abelian Period

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/131072 K (Java/Others)
Total Submission(s): 524    Accepted Submission(s): 222


Problem Description
Let S be a number string, and occ(S,x) means the times that number x occurs in S.

i.e. S=(1,2,2,1,3),occ(S,1)=2,occ(S,2)=2,occ(S,3)=1 .

String u,w are matched if for each number i , occ(u,i)=occ(w,i) always holds.

i.e. (1,2,2,1,3)(1,3,2,1,2) .

Let S be a string. An integer k is a full Abelian period of S if S can be partitioned into several continous substrings of length k , and all of these substrings are matched with each other.

Now given a string S, please find all of the numbers k that k is a full Abelian period of S .
 

Input
The first line of the input contains an integer T(1T10), denoting the number of test cases.

In each test case, the first line of the input contains an integer n(n100000) , denoting the length of the string.

The second line of the input contains n integers S1,S2,S3,...,Sn(1Sin), denoting the elements of the string.
 

Output
For each test case, print a line with several integers, denoting all of the number k . You should print them in increasing order.
 

Sample Input
2
6
5 4 4 4 5 4
8
6 5 6 5 6 5 5 6
 

Sample Output
3 6
2 4 8


问题描述

S是一个数字串,定义函数 occ(S,x) 表示 S 中数字x的出现次数。

例如: S=(1,2,2,1,3),occ(S,1)=2,occ(S,2)=2,occ(S,3)=1

如果对于任意的 i ,都有occ(u,i)=occ(w,i),那么我们认为数字串 u w匹配。

例如: (1,2,2,1,3)(1,3,2,1,2)

对于一个数字串 S 和一个正整数k,如果 S 可以分成若干个长度为k的连续子串,且这些子串两两匹配,那么我们称 k 是串S的一个完全阿贝尔周期。

给定一个数字串 S ,请找出它所有的完全阿贝尔周期。

输入描述

输入的第一行包含一个正整数T(1T10),表示测试数据的组数。

对于每组数据,第一行包含一个正整数 n(n100000) ,表示数字串的长度。

第二行包含 n 个正整数S1,S2,S3,...,Sn(1Sin),表示这个数字串。

输出描述

对于每组数据,输出一行若干个整数,从小到大输出所有合法的 k

输入样例
2
6
5 4 4 4 5 4
8
6 5 6 5 6 5 5 6
输出样例
3 6
2 4 8

解题思路:

首先我们可以进行分割的话,一定是分的 n 的因子数,所以我们首先将 n 的因子数分解出来,然后分段统计每个数的个数就好了,首先我们定义两个 mp1  mp2 mp1 记录的是开始的那个每隔 fac[i]() 的个数,然后循环找 mp2 ,它记录的是后面的每隔 fac[i] 的个数,当 mp1[a[k]]>mp2[a[k]] 的时候就跳出,开始执行下一个因子(因子是从小到大排的)。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cstdlib>
#include <bitset>
#include <map>
using namespace std;
typedef long long LL;
const LL MAXN = 1e5+5;
LL a[MAXN];
LL fac[MAXN];
map<LL,LL>mp1;
map<LL,LL>mp2;
LL ans[MAXN];
int main()
{
    LL T;
    scanf("%lld",&T);
    while(T--){
        LL n;
        scanf("%lld",&n);
        LL cnt = 0;
        for(LL i=1; i*i<=n; i++){
            if(n % i == 0){
                if(i*i != n)
                    fac[cnt++] = n/i;
                fac[cnt++] = i;
            }
        }
        sort(fac, fac+cnt);
        for(LL i=1; i<=n; i++)
            scanf("%lld",&a[i]);
        mp2.clear();
        mp1.clear();
        LL cnt1 = 0;
        for(LL i=0; i<cnt; i++){
            mp2.clear();
            for(LL j=1; j<=fac[i]; j++)
                mp2[a[j]]++;
            int ok = 0;
            for(LL j=1+fac[i]; j<=n; j+=fac[i]){
                mp1.clear();
                for(LL k=j; k<j+fac[i]; k++){
                    mp1[a[k]]++;
                    if(mp1[a[k]] > mp2[a[k]]){
                        ok = 1;
                        goto endW;
                    }
                }
            }
            if(!ok)
                ans[cnt1++] = fac[i];
            endW:;
        }
        for(LL i=0; i<cnt1; i++)
            if(i != cnt1-1)
                printf("%lld ",ans[i]);
            else
                printf("%lld\n",ans[i]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值