HDU 5776 sum ( BC #85 1001)

77 篇文章 0 订阅

sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 840    Accepted Submission(s): 393


Problem Description
Given a sequence, you're asked whether there exists a consecutive subsequence whose sum is divisible by m. output YES, otherwise output NO
 

Input
The first line of the input has an integer T ( 1T10 ), which represents the number of test cases. 
For each test case, there are two lines:
1.The first line contains two positive integers n, m ( 1n100000 1m5000 ).
2.The second line contains n positive integers x ( 1x100 ) according to the sequence.
 

Output
Output T lines, each line print a YES or NO.
 

Sample Input
  
  
2 3 3 1 2 3 5 7 6 6 6 6 6
 

Sample Output
  
  
YES NO

分析:首先预处理一下前i项的和,然后sum[ i ] %m 如果出现大于1次,说明其中包含子序列为 m 的倍数 ,相当于(sum [ i ] - sum [ j ])%m==0  ( i > j)

代码如下:

#include <stdio.h>
#include <string.h>
int main()
{
	int T;
	int n,m,i,j;
	int a,sum[100010],ans[5005];
	scanf("%d",&T);
	while(T--)
	{
		int peace=0;
		memset(ans,0,sizeof(ans));
		memset(sum,0,sizeof(sum));
		scanf("%d %d",&n,&m);
		sum[0]=0;
		ans[0]=1;
		for(i=1;i<=n;i++)
		{
			scanf("%d",&a);
			sum[i]=sum[i-1]+a;
			ans[sum[i]%m]++;
		}
		for(i=0;i<=m;i++)
		{
			if(ans[i]>1)
			{
				peace=1;
				break;
			}
		}
		if(peace)
			printf("YES\n");
		else
			printf("NO\n");
	}
	
	return 0;
} 



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值