hdoj5776 sum

sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 493    Accepted Submission(s): 236


Problem Description
Given a sequence, you're asked whether there exists a consecutive subsequence whose sum is divisible by m. output YES, otherwise output NO
 

Input
The first line of the input has an integer T ( 1T10 ), which represents the number of test cases. 
For each test case, there are two lines:
1.The first line contains two positive integers n, m ( 1n100000 1m5000 ).
2.The second line contains n positive integers x ( 1x100 ) according to the sequence.
 

Output
Output T lines, each line print a YES or NO.
 

Sample Input
  
  
2 3 3 1 2 3 5 7 6 6 6 6 6
 

Sample Output
  
  
YES NO
 

Source



要求从题目所给的数串中判断是否存在连续子串之和能整除m

定义一个sum加上输入的数,每每加上一个数就取m的模,存在两个相同的余数,说明中间的数能构成m的整数倍

这个坑在于。。。save[0]要先定为true

下面是代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
bool save[5005];
int main(){
    int t,n,m,i,now,god;
    scanf("%d",&t);
    while(t--){
        god=0;
        scanf("%d%d",&n,&m);
        memset(save, 0, sizeof(save));
        save[0]=1;
        int sum=0;
        for(i=1;i<=n;i++){
            scanf("%d",&now);
            sum=(sum+now)%m;
            if(save[sum]){
                god=1;
            }
            save[sum]=1;
        }
        if(god){
            printf("YES\n");
        }else{
            printf("NO\n");
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值