Poj 2689 Prime Distance(素数筛+二次素数筛)

传送门

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers.

Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).

Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.

Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

Sample Input

2 17 
14 17

Sample Output

2,3 are closest, 7,11 are most distant. 
There are no adjacent primes.

题目大意:

给定一个 [l, r] 的区间,让你求相邻素数的的最远距离和最近距离,相邻素数是指两个素数中没有其它的素数。

解题思路:

给定的 l 和 r 的范围太大,但是他们的区间差并不是很大,我们可以从这里面做文章,首先我们可以利用一次素数筛,筛掉 12,147,483,647 之间的素数,然后我们在 [l, r] 区间中筛掉是合数的部分,怎么筛呢? 首先我们发现 [l, r] 中间的数如果是合数的话,那么一定对我们第一次筛出的素数的某几个数字取模等于零,也就是因子,利用这个性质,我们就可以筛出所求区间中所有的合数,首先我们计算一个左边界 a=l1pi+1 ,右边界 b=rpi ,然后枚举 [a, b] 区间中所有的数,还得判断一下 a 是不是 >1 ,如果是 1 的话 说明 l 是一个素数,或者 l<pi,然后不做处理,否则就进行筛。
还有一个小 trcik: 当 l 是1 的时候,我们当做素数处理了,需要特判。
最后统计一下就行啦。

代码:

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#include <string.h>
#include <algorithm>
using namespace std;
const int MAXN = 5e4+3;
const int MAXM = 1e6+3;
int cnt;
int p[MAXN];
int prime[MAXM];
void isPrime(){
    memset(prime, 0, sizeof(prime));
    prime[1] = 1;
    cnt = 0;
    for(int i=2; i<MAXN; i++){
        if(!prime[i]){
            p[cnt++] = i;
            for(int j=(i<<1); j<MAXN; j+=i) prime[j] = 1;
        }
    }
}
int p2[MAXM], cnt2 = 0;
void isPrime2(int l, int r){
    memset(prime, 0, sizeof(prime));
    if(l < 2) l = 2;
    for(int i=0; i<cnt; i++){
        int a = (l-1)/p[i]+1, b = r/p[i];
        for(int j=a; j<=b; j++) if(j > 1) prime[j*p[i]-l]=1;
    }
    cnt2 = 0;
    for(int i=0; i<=r-l; i++)
        if(prime[i] == 0) p2[cnt2++] = i+l;
}
int main()
{
    isPrime();
    int l, r;
    while(~scanf("%d%d",&l,&r)){
        isPrime2(l, r);
        int ans1 = 0, ans2 = MAXM, ans1_i, ans1_j, ans2_i, ans2_j;
        for(int i=1; i<cnt2; i++){
            if(p2[i]-p2[i-1] < ans2) ans2 = p2[i]-p2[i-1], ans2_i=p2[i-1], ans2_j=p2[i];
            if(p2[i]-p2[i-1] > ans1) ans1 = p2[i]-p2[i-1], ans1_i=p2[i-1], ans1_j=p2[i];
        }
        if(cnt2 >= 2)
            printf("%d,%d are closest, %d,%d are most distant.\n",ans2_i,ans2_j,ans1_i,ans1_j);
        else
            puts("There are no adjacent primes.");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值