POJ - 2689 Prime Distance —— 二次筛

Prime Distance
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 20935 Accepted: 5629

Description

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers. 
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).

Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.

Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

Sample Input

2 17
14 17

Sample Output

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.

Source

题意:给定两个数l和r,求l到r之间距离最小和最大的两组素数

思路:l和r的范围很大,不能预处理出来所有的素数,但是每组l,r间的差值很小,所以只能每次筛出l,r间的素数,而筛的时候最多只会用到sqrt(2e9)内的素数,所以先把这里面的素数筛出来,然后用这些素数去筛每组l,r间的素数

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <cmath>
#include <vector>
#define max_ 1000010
#define inf 0x3f3f3f3f
#define ll long long
#define les 1e-8
#define mod 9901
using namespace std;
ll prime[50000];
int pl=0;
const ll n=2147483647;
bool vis[1000010];
ll p[1000010];
void getprime()
{
	for(ll i=2;i<=50010;i++)
	{
		if(vis[i]==false)
		prime[++pl]=i;
		for(int j=1;j<=pl&&i*prime[j]<=50010;j++)
		{
			vis[i*prime[j]]=true;
			if(i%prime[j]==0)
			break;
		}
	}
}
int main(int argc, char const *argv[]) {
	ll l,r;
	getprime();
	while(scanf("%lld%lld",&l,&r)!=EOF)
	{
		int cnt=0;
		memset(vis,false,sizeof vis);
		for(int i=1;i<=pl;i++)
		{
			int k=l/prime[i];
			while(k<=1||k*prime[i]<l)
			k++;
			for(ll j=k*prime[i];j<=r;j+=prime[i])
			{
				if(j>=l)
				vis[j-l]=true;
			}
			if(l==1)
			vis[0]=true;
		}
		for(ll i=0;i<=r-l;i++)
		{
			if(vis[i]==false)
			{
				p[++cnt]=i+l;
			}
		}
		if(cnt==0||cnt==1)
		{
			printf("There are no adjacent primes.\n");
			continue;
		}
		int minn=inf;int maxx=-1;
		ll minnk1,minnk2;
		ll maxxk1,maxxk2;
		for(int i=2;i<=cnt;i++)
		{
			if(p[i]-p[i-1]<minn)
			{
				minn=p[i]-p[i-1];
				minnk1=p[i-1];
				minnk2=p[i];
			}
			if(p[i]-p[i-1]>maxx)
			{
				maxx=p[i]-p[i-1];
				maxxk1=p[i-1];
				maxxk2=p[i];
			}
		}
		printf("%lld,%lld are closest, %lld,%lld are most distant.\n",minnk1,minnk2,maxxk1,maxxk2);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值